eWeLink app doesn’t pick wifi SSID

I had bought several sonoff smart wifi switches to install in my home but I can’t even pair one of them. I am stuck for the last 3 hours trying to pair. The app doesn’t even select the router wifi ssid. I disabled 5ghz completely but still the app’s SSID field doesn’t get populated when I change or reselect in my iPhone settings. Please assist as I am really stuck. Even the compatible mode doesn’t work , as that too ends on the same screen asking to select SSID.

1 Like

Hi! The GPS on the phone is enabled? Honestly I’ve never understand why, but if is not enabled the ewelink app do not catch the wifi SSID…

1 Like

Hi there. Yes the gps is always on. I updated location services to always for this app but still does not work. Weird thing is that it worked briefly for very first time but I was unable to pair it that time. Tried again so many times and it just does not work.

Please place a screenshot with the SSID pick page, let me check.
According to Apple and Google’s request for Apps, lactation access and precise location should be allowed and ON when pairing.

1 Like

I don’t have an answer for you. But I too had this problem about 5 months ago. I wrote a trouble ticket and complained. Two days later, but before they got back to me, I tried again, and I was able to get pass that problem. Same app version, nothing had changed. Just worked.

By the way, I hate how the made that “click to okay” the same color. Hard to determine that its not already 'clicked", and that we must do it every time. Waste of a finger click.

Good luck. I know I didn’t solve it. But I hope I helped.

1 Like

Thank you. Everything was exactly as shown from the beginning however it didn’t work before but is working now.

As a matter of fact that was my exact situation. It didn’t work in the weekend but I tried again this week with same exact settings and it worked!

I have used sonoff products before and I must say they are good , but the app itself has to be amongst the worst.

I also don’t understand the need for the app to know our precise location. I am using a different brand smart switch as well and that doesn’t ask for precise location. I know many people are avoiding this product for this reason.

eWeLink doesn’t need the location at all, However, Apple and Google require this when the App calling the wifi API when paring.

Makes sense, thanks. Would it be okay to turn off location settings since wifi pairing is now complete?

As a sanity check try taking 1 device around to a friends house and try to connect with his wifi if that works it could be an issue with your router

It was a weird issue but resolved now. Nothing to do with the router. It was not working and I tried again few days later with same settings and worked just fine. I have come across a few people who had same issue at some point in time.

It’s OK to disable the precise location setting when paring completed.
Hoping iOS and Android remove this requirements in the future.

1 Like