Need urgent help pairing sonoff zigbee bridge!

For the love of god for some reasaon no way in hell i can pair my sonoff zigbee bridge non pro with the eWelink app !! Been trying for days! … When I put it to pair mode and give it wifi info for my 2.4ghz wifi I see it show up in router, but app says there are no devices found, no amtter how much i try… even tried 30 different older app versions, nothing! it does blink twice a second, I’m guessing that means it cannot connect to server, I’ve tried on 3 different networks with different ISP’s none can connect so it’s nto a ISP blocking! PLEASE HELP, WHAT DO I DO!

I assume you reboot the router? Maybe the device is moving to another home and you are looking for it in another?

I am a system admin so i’ve rebooted the router 50 times, and no it’s not moving to no other home because as stated i cannot even pair it … it’s searching, than says no device found, and according to official site 2 quick flashes a second means it’s connected to network which i’ve verified by it being in ARP in router as a connected client, but wont connect to server according to what 2 flashes a second mean

I’ve spent a bit over 300€ but cannot use any because i cannot pair the sonoff zb bridge to my app to start using other stuff

If the device has a correctly programmed WiFi network, it should connect to your WiFi router and maintain this connection, even if it is unable to connect to the cloud or your Internet is offline, the bridge will still be connected to your WiFi.

Check whether the device actually has Wi-Fi connected all the time, and not just whether it appears for a moment.

Also make sure you are not blocking access to WiFi via MAC.

Some Sonoff WiFi devices have problems with establishing and maintaining WiFi connectivity on some routers, they need something like the “Allow legacy 802.11b rates” option, which is available in OpenWrt.

It shows up in my ARP table in my router and on my accesspoint cluster ARP so it’s connected to my network 1000000%, dosent show up in the ewelink app at all…

i can even move it to another 2.4ghz WIFI network with different SSID… and it does move there app still dosent find it during pairing…

Also no option og 802.11B on my stuff, at lowest 802.11GN

And have you tried both adding modes in the app?

I’ve tried bluetooth and the “standard” one without pressing “more pairing options”

According to the documentation… Quick Pairing Mode / Compatible Pairing Mode

My guess is than the one i thought “is standard” is quick right? the one that happens the sec you press add without going to more options? yeah tried that one about 25000 times, and i did try compatible but asks for the bridge’s wifi but the bridge dosen’t transmit any wifi SSID to connect to … maybe it did before i tried first connecting it and is now gone, but atm i do not see it …

Restart your device and start from scratch again…

Factory Reset

Long press the pairing button for about 5s until the Wi-Fi LED indicator changes in a cycle of two short and one long flash and release, then the reset is successful. The device enters quick pairing mode

that puts it into pair mode for 3 minutes, than it stops blinking like that…
done that 5746843543 times …

Do this again and try moving closer to or away from the device. It may be a signal problem sometimes the app does not detect the device.

i havent thought of moving further… will try now i guess

Do you have bluetooth turned on on your phone?

I have everything possible on, bluetooth, location, wifi … it refuses to pair without those (or atleast confirmed without location and wifi obviously maybe could disable bluetooth)

Hmm, but since you were able to add WiFi to the device earlier,
means that pairing was successful one time and the device should appear in the ewelink app. at most it can be visible offline, but it has to be.

1 Like

The device also needs to have free access to TCP 443, 80, 8080 and DNS servers, otherwise it may have problems connecting to the cloud.

1 Like