Docker add-ons not working after V 1.13.4 upgrade

After upgrading to V1.13.4 my Docker add-on applications stopped working (eWelink, Node-Red and Tailscale). I can see them in the add-on list and can select them, but the GUI’s will not open. I can display the info tab, but the add-on logs stopped when the iHost was rebooted during the V1.13.4 upgrade, so there is no info available there.

When I try to operate a device, the iHost returns a message that the eWelink service is not available. Tried to uninstall and reinstall the ewelink add-on, but the install just sits there doing nothing.

I did open a ticket via the iHost feedback function, with iHost log attached. Still waiting for a response.

I have this horrible feeling that the TF card got corrupted during the V1.13.4 upgrade process. Anyone with similar experience?

I must add that I have full control of all my devices via the eWelink app as well as via the Web interface - the issue is localised on the iHost. Thank goodness I kept the smart scenes updated on the app as a backup, and could fall back to those.

Update - Received confirmation that ticket 204425 was opened (Eric)

1 Like

Try clearing your web browser cache.

Sounds like a cache or browser issue.
Try one of the method to be sure:

  1. Clear the cache of your browser.
  2. Open your iHost web with Incognito window.
  3. Open your iHost web with another browser.

Tried that - results the same. Edge or Chrome, clearing cache, no difference. The symptoms are exactly the same.

I doubt very much that the problem is related to my browser environments, because I cannot even reach the iHost via Tailscale any more. And that is not dependent on my browser as far as I know.

Anyway - let us see what support finds in the iHost logs that I sent with ticket 204425

The ticket is received.
We’ll check what’s wrong.

@ jam3 - As I stated above: “When I try to operate a device, the iHost returns a message that the eWelink service is not available”. My interpretation is that the integration between the iHost core and the Docker has some problem here. It is not specific to a particular add-on: - all of my add-ons stopped working. My reference to not being able to open an add-on GUI is just one of the symptoms.

The core iHost is functional and I can navigate anywhere on the main menu - it is only the Docker add-ons that are not working. I can even edit my smart scenes and query their logs, but these are all managed by the iHost core and not by an add-on.

The moment the iHost has to rely on the docker add-on is where my problem is hiding… We will see what support finds in the logs.

Perhaps removing and reinstalling the add-ons will make a difference. Have you tried doing this?

I did, on the eWelink add-on. No difference to the symptoms at all. I suspect that the issue is when the iHost core starts up the add-on services after reboot. But I am speculating off the back of gut-feel from my many years of IT experience, with very little insight into the actual iHost code :slight_smile:

You mentioned a possible SD card failure. I assume you’ve already tried with another one, yes?
The question is whether exactly these add-ons are stored on the card. eWeLink has never revealed what actually goes on the memory card. Almost nothing is known about the storage structure of the iHost.
Not really sophisticated advice, but have you considered swapping iHost for an HA server? Hardware-wise iHost is almost flawless, but everything else sucks. Since I got rid of iHost with some regret and switched to RPI with HA, I have nothing to write about on this forum. Sonoff devices are better supported on HA than on iHost, which is surprising indeed and should be an embarrassment to the proprietary software developers. I now have a hybrid solution. A small and necessary part of the automation support is still in the eWeLink cloud (with NSPanel Pro as the “central device”), everything else is on HA.

SD card failure - I changed my opinion about that possibility - I know the add-ons are installed on the SD card and I was able to remove and install the eWelink add-on. So probably not the card, but I do not have a spare to do a test - also, I want to give support a constant environment for debugging and not change too many things right now.

In terms of the iHost itself - I was already heavily invested with Sonoff devices and have about 70 deployed. What appealed to me was the local control - but as we discovered on this forum, the iHost is not really a local host - it is an integration hub and still needs the cloud services available for some tasks. So I was using it to learn, waiting for it to become more stable and useful, but always keeping my smart scenes updated on the eWelink app as a backup. Right now I am very happy that I did, else I would be extremely upset. My entire home and property is automated…

Then I discovered NodeRed and developed a number of flows to control lights, water pumps, water storage, irrigation… I even built my own irrigation controller. With the problem I have now I lost this functionality (including whatsapp and telegram notifications) and had to fall back on basic smart scenes. I might be tempted to move away from the iHost just for this reason - to have a stable Node-Red local host environment. You are not the first person suggesting the HA platform.

However - the iHost has come a long way since the early very shaky versions - I started with V1.1… I might stick it out for a while longer and see how it develops. But not really a production consumer product yet - strictly for DIY type people with technical capabilities…

Similar behaviour from my iHosts (I have two) after the 1.13.4 update:

  • No Docker applications are available via the iHost web interface.
  • eWeLink devices are reporting that they are off-line.

After a reboot:

  • The eWeLink devices on one of my iHost devices are available, but only about half are “on-line” on the other iHost device. The add-on is not accessible in the iHost web interface.
  • My Node-RED flows seem to be working, but I can only access Node-RED directly using the URL with the port specified to get to it outside the iHost web interface.

As soon as I posted, the Docker add-ons started working, again. The supposedly-off-line eWeLink devices on the second iHost device have not come back on-line, yet, even after downloading the available Node-RED and eWeLink Smart Home updates.

The second iHost’s missing devices show up in the cloud; I will have to wait until I can be on the same network to see if I can add them back.

If Cube developers are airing their issues and concerns with the iHost platform, what hope have we got? In my world of software development, a developer who stated on a public forum, their concerns with a particular product, would have a very short time remaining at the company. I don’t wish this on anyone who is willing to support us to make a better product but it does illustrate the depth of the problems we experience.


The badge was given to third-party developers who are interested in contributing to CUBE add-ons. They are not official dev of the system eWeLink CUBE.

I have the iHost RV1126 DDR4 4GB with v1.13.4 firmware that does not have any problems with the Docker add ons.

After reading the log, here are some question I need your answer.

  1. It’s everything working fine except the add-ons(including smart-home add-on, node-red, etc)?
  2. Can you try visit add-on webui with the button on the right?
    And see if the page working?

If the page don’t working.
Please send us the smart-home add-on as well.

Hi SuiKa

  1. Yes – it looks like everything else is working fine. I can freely navigate to all iHost menu functions and can edit smart scenes. Only the add-ons that are not working. For your information – I updated Smart-home and NodeRed to the latest versions shortly before doing the V1.13.4 upgrade.
  2. I tried to visit the web UI as you asked, but it tells me the page cannot be found (port 8321). I tried it also from the info tab:

For NodeRed the same, but for port 1880 of course

As requested, the smart-home log is attached. However, it stopped recording from the reboot after upgrading to V1.13.4 - so what you see here is probably before the reboot

f4af0daf-5675-4fcd-8247-d1b3813a5fcb.txt (182 KB)

Did you upgrade your iHost after the time 2024-03-18T10:50:22(UTC time)?
Cause I can’t see any log after the time.

Is the node-red page shows the same error?

Correct, the iHost was rebooted after that time and no new log entries were created after that.

And yes - the NodeRed page shows the same error (page not found), but for port 1880 of course.

I remind you of a comment I made early in the thread - when I try to control a eWelink smart home device from the iHOst, I get an error that the service is not available…