Devices randomly turning off by themselves

I have around 80+ sonoff devices. They randomly switch off by themselves. They stop doing this if you bind/reserve the mac address. The issue is that you only reserve 40 mac addresses on most routers. This is becoming a very serious issue for me. I’ve found similar complaint online and on this forum. The ewelink/sonoff team is not doing anything to help.


Check this topic:

1 Like

You may have reached the MAX WIFI CLIENT CAPACITY of your router. That is a different parameter than the DHCP number of IP address you configure. In practical terms it applies the lower of the two. If your router can serve max 32 wifi clients (layer 2 capacity) and your DHCP range is set to 80 (layer 3 capacity), your network will allow only 32 connections. That will result on all devices connecting and disconnecting randomly. You can alleviate that changing the ADVANCE WIFI CONFIGURATION of your mobile devices (tablet, notebook and sma rtphones), switching USE RANDOM MAC ADDRESS to USE DEVICE MAC ADDRESS. If you find at least one and after fixing all mobile devices, you will need to power cycle your router to release wifi buffers.

Hope this helps…

Thanks for the reply, I did a factory reset on the router and the problem seems to be solved.
I have a Tplink AX11000 router and can handle over a 100 clients

1 Like

Hello, I too am revealing problems with the latest version 4.29.1, the devices are activated autonomously for a few tenths of a second, I have been using sonoff for years and have never had such problems! If I turn off the wifi I have no more problems! so surely the problem is caused by the app.
he keeps doing it day and night! so i have to turn off the wifi.