Creating an automatic ZigBee switch scene in eWeLink app

I’m trying to create a scene that automatically turns off a ZigBee switch 5 minutes after it was turned on.

With Tuya devices, it’s pretty easy. In the eWeLink app, when I select a specific device as a trigger, I can’t get it to perform any action.

In the example in the image, the device is “Corredor”. Am I doing something wrong?

The rule engine in EWeLink is pretty primitive. I would suggest you expose all your ewelink devices to Smartthings and run automations from Smartthings app. Quick and Reliable.

make a manual scene that turns off the Corredor after 5 minutes

1 Like

In eWelink, it is not possible to select the same device in IF and THEN, but it can be bypassed by creating a manual scene to turn off the “Corredor” device, and then adding this manual scene to the delay …

1 Like

Yes, that’s what I had to do. Do you know if this is a limitation of the ewelink platform?

Unfortunately, yes, it’s a limitation in eWelink and I don’t understand why, then I have to unnecessarily create manual scenes and bypass the limitation in various ways. I have tried others (BlitzWolf, LSC - same applications…), there you can select the same device for both IF and THEN. But again in favor of eWelink - they are trying to improve the application, I don’t even remember any major improvements for the aforementioned.

1 Like


Single-channel switch type devices are not allowed to be used as trigger conditions and execute actions at the same time in a scene, which may be the logic to avoid the scene loop putting a huge strain on the server, let me think about it…

If I create a manual scene (MS) where the status of device A (Reverse) is to be changed and for this I create an automatic scene for example:
IF Device A state is On AND temperature <= 20
launch (MS)

it’s the same as what the automatic scene would do without the (MS) if it could be used:
IF device A status is On AND temperature =< 20
device A - Reverse

and there would be one less unnecessary manual scene and at the same time it would make the scenes clearer.

After just rolling it out (Reverse instead of just On and Off) I redid the automatic scenes with the RF states and then halved the number of them than needed before and got rid of all the supporting manual scenes as well.

Why do t you put an inching setting on that device for 5 minutes. That should solve your issue.

Because ZigBee devices don’t have inching function.