Compatibility with SONOFF 433 RF BRIDGE MHZ and SCENE/WebHook

Hello everyone, I recently purchased a Sonoff 433 RF bridge with an RF button, and when installing the evelink app, this worked wonderfully,

For the previous result, i decided to take it a step to implement output json messages with Webhook, so I purchased the paid subscription to get this functionality.

Motivated to do this implementation and seeing how to worked, now when creating a scene through evelink web, it does not recognize my device in the list.

Additionally, it appears within the automatic scenes, the one I made with the evelink app, but it throws up a scene message that is not supported.

Does anyone have any idea how I could perform this simple function?
for know if it is a system problem, or definitely evelink web does not have support like this simple one button function.

Thank you all!

Run ewelink app, make sure that you have correctly added RFBridge433 and the button added to it and it is programmed.
Create a scene in the ewelink app, select Smart Device/RFBridge433 and then the device that is added to RFBridge433. Select some tasks for the scene and finish creating.

Now go to the WEB panel and edit that particular scene and add/improve its features but do not touch the “if” section of “Smart Device”.

If the scene is created in WEB, after selecting Smart Device there is no RFBridge433. It is not possible to further select which device is connected to RFBridge433.

I always add such a scene via the ewelink app and then edit it in WEB. This way I can select RFBridge433 and select which sensor is connected to it.
Although the last sensor field is always empty in WEB, it will look and work correctly in the ewelink app.

Of course, adding a device to RFBridge433 and configuring the sensor must first be done in the ewelink app. Then the scene and only further configuration in WEB to add a webhook.

For me, the WEB panel never worked properly with the RFBridge433 and the devices connected to it.

Can you share your script and describe your webhook solution?

Dear Morgan, thank you very much for the information. I tried to do what was described and I was able to make web diagrams and the RF bridge appears, but unfortunately, even though it is there, it does not run when I press the RF button. I have even tried to run other scenes from my cell phone, but it hasn’t worked either. Another strange thing that happens is that those scenes that I build on the cell phone, when I modify them later on the web platform with webhook, these scenes disappear from the phone, and only remain on the web.

I don’t know what else I could do, if I feel very sad since it is the only thing I need to finish.

Regarding the code, here I share the code:


     case 'POST':
         $data = json_decode(file_get_contents('php://input'));
         if($data != NULL) {
             if(sesdata::insert($data->button)) {
             }//end if
             else {
             }//end else
         }//end if
         else {
         }//end else

Start again from the beginning. Delete everything and start from scratch. :slight_smile:

Step one, in the ewelink app, make sure that we have added the RF Bridge and the remote control is also added to the bridge and has programmed button(s).

Step two, in the ewelink app, go to “Scene” and add a new item by pressing “+”.

Step three, in the “If” section, add “Smart Device” then select “Sonoff RF Bridge” then select “My Remote” then select button number “Button1” and save.
The names may vary slightly for you.

Step four, in the “Then” section, repeat exactly the same as in step three. This may seem illogical, but it is just a trick to create a scene that we will later set correctly in ewelink WEB.

Step five, Go to ewelink WEB, then “Scene”, select the previously created scene for editing.

Step six, we edit the scene, we do not change the “If” position, we are only interested in the “Then” position. Delete the current item there and then add a new “WebHook” item and configure it as needed, then save the scene.

Step seven, that’s it, test the scene and it should work as follows. When you press physical button number 1 on your remote control, a scene should be executed that activates your webhook.
The gray item next to Sonoff RF with “Scene not supported” is a normal situation, it is an RF handling error in the ewelink WEB and nothing can be done about it, but it does not affect the operation of the scene.

Suggestion, make sure that your webhook actually works before you focus on ewelink. It may be that it is not a problem on ewelink’s side to make the call to your webhook.

Make sure that your RF button/remote works properly and that your RF Bridge connects correctly to the ewelink cloud.

Remember that this scene only works when RF Bridge is connected to the Internet and is therefore able to communicate with the cloud. If the connection is offline no scene will work, RF Bridge does not support local/offline scenes, everything is cloud based unfortunately.

Observation, it is true that after editing the scene in WEB, it disappears in the ewelink app. This is a symptom and we cannot do anything about it from the user’s side, just as we have no influence on the error of adding RF devices in WEB ewelink.

The above method of creating a scene for the RF device and webhook works 100% for me, tested!

Unfortunately, sonoff/ewelink, as the company’s products, have a lot of errors and unfinished items.

Summary, the above method is the only one I know that allows you to add RF devices to the scene in which we want to have a webhook.
In ewelink WEB we will not add the RF device correctly in the “If” section and in ewelink app we will not add the webhook for our scenes correctly.
WEB does not fully handle RF devices paired with RF Bridge.
And the webhook option is only available in WEB because of the “Advanced plan” and is not available in the ewelink app. Somewhere along the way, someone on the dev team didn’t think through the usage pattern. :slight_smile:

I had to develop this method myself because no one mentions it anywhere.

When we try to create a scene in ewelink WEB and in the “If” or “Then” section we want to have an RF device. Yes, we can select “Smart device”, but later we will not find our RF Bridge on the selection list. This means we will not add RF in the scene via WEB.

In the ewelink app, when we create a scene, we can easily select the RF device, but we have no webhook option at all.
Of course, the account is in the “Advanced plan”, but the webhook option does not appear even in version 5 of the app.


“Pressing a button” to trigger an action… I’m talking about a physical button/remote control that you hold in your hand. This icon in the WEB panel is not a button that will trigger an action when clicked!
If you want to have a virtual button to launch the action, create a scene in WEB where in “if” you select “Tap to run” and in “Then” WebHook.

Dear Morgan, yes, this now works with the physical button. Thank you very much for this great advance for my project. I followed the information to the letter and at least I reached the service.

The problem I have now is that through the post method I must send a parameter like the one I have below:
{“data” :“+56STGO”}

Using the soap ui tool, the information works smoothly.

But when using ewelink webhooks, I can consume the service, but the sent parameter does not arrive.

These are the screenshots of what happens.

I use for testing and it returns the following with your parameters…

Description--> {“data” :“+56STGO”}

“description”: “{“data” :“+56STGO”}”,
“triggerType”: 3001

Description--> +56STGO

“description”: “+56STGO”,
“triggerType”: 3001

Do you actually need to process the entire parameter this way? Can you specify just +56STGO? Do you need “data” on your side for processing?

However, from a place other than ewelink…
Raw Content

{“data” :“+56STGO”}

Incidentally, something very odd is going on with the RF bridge at the moment. I don’t use webhooks but all my automations using an iHost stopped whilst those in the phone App continued. I set up some new scenes using them and then in the middle of the night the scenes randomly ran.

ps. I only recently discovered the free app called ‘Olisto’ that connects to eWeLink has webhooks because they don’t call them webhooks. I think their term is “connections”. You may be able to achieve what you want without an eWeLink advance plan.

Dear Morgan, thank you very much for your detailed advice. Indeed, ewelink’s webhokks does not have a body in post responses, so it is only limited to using “description” to send parameters. I made the respective change in the api, and it worked wonderfully.

I greatly appreciate your help.


1 Like