Alexa routines, can’t use switches as triggers

Hi! I recently started with the configuration of my home with a lot of sonoff smart switches and Alexa. Everything goes well, but since yesterday I cannot do a new routine using switches as triggers . It only shows blink cam’s, Nuki device and my son echo show 3. Nothing more, any idea? I’ve tried to deactivate the skill and activate it again. But nothing. Please help ! Ty!

Hi. In Alexa, only a few devices support use as triggers, most use as actions. I guess that’s why you can’t see your switchs in the trigger list.

Hi! That’s right, but a few days earlier i made a lot of routines using this switches as triggers. Now the routines are atolladero working but ir you edit the routine it doesn’t show the trigger anymore.

El El lun, 27 de jun. de 2022 a la(s) 07:20, Erin Lin via eWeLink Forum <notifications@ewelinkforum.discoursemail.com> escribió:

May I have the device ID of your switch?

Now I have deleted all. I’m trying all again ….

El El lun, 27 de jun. de 2022 a la(s) 07:43, Erin Lin via eWeLink Forum <notifications@ewelinkforum.discoursemail.com> escribió:

Like @Erin aid, most devices in Alexa can only be set as actions, that’s a limitation of Alexa.
actually, we are working with Alexa team to integrate a beta version of API, which enable the device as trigger, once we finished the integration will roll out this feature to you.

ty for the answer. i thought that it was available cause i made many routines last week. ok I look forward to it. ty again

sebastian

1 Like