[Alexa related issue]Sonoff devices are automatically and randomly turning off

Yes. But since Ewelink does not answer what is going on and why this is happening nothing indicates that it will not happen again with the new IP.

Please Ewelink answer something. You should not maintain all Ewelink customers in the dark regarding this issue. In a very litle amount of time all Ewelink customers will move to other solutions based on Smart Life that do not create this problem. Kind rfegards,

1 Like

Yes, changing the IP in the router MAC table solves the problem. But my router only allows me 8 IP reservations… Not enough for all my Sonoff devices…

As indicated before, until EWELINK indicates what is problem we cannot say that changing the IP solves the problem. The IP by itself is not a problem, it has to be something else what is causing the troubles.

Ewelink should not remain silent about this issue since we need to take a decision, whether to keep using Ewelink devices, or move to Smart life and abandon Ewelink.
Please EWELINK !!!Say something about this issue¡¡¡¡¡


You’re right, but until eWelink does something, change the IP it’s the only way to not being annoyed with lights going off.

Any mail where we can bomb them until the problem is solved?


No idea how to push EWELINK supporters to take a look to this problem. It should be realtively easy for someone that know what he is doing to address the issue.

I look at the log of the router and, what I see, is that the device looses the wifi conection and recovers inmediately. Then it goes again to the DHC routine to request a new IP. When loosing connection the device goes to the requested state in the configuration that normally is OFF.

1 Like

Hello Ewelink. Any news regarding this problem?

Please at least answer that you consider this issue important since it is affecting many Ewekink users that will go to the category of Ex-users pretty soon.

Just to inform the Ewelink community that Using Smart Life devices you WILL NOT experience this problem.

Ewelink should at least inform us if the problem is related with AMAZON Echo or any clue of the origing of the problem.

In my case it does, it’s been a week and a half without any off/on.
But still waiting for an explanation and a real solution.


Same problem, since about one month ago… i’m going to try and fix with the IP static configuration… I hope EWELINK can give us an accurate explanation.

Hello Ewelink. Please tell us something about this problem:

  • Is it rekated to Amazon Echo?
  • Is it related to any option of DHCP?
  • Is it related with the Sonoff device restarting unexpectedly?
  • Any clue why some devices are affected and other are not?

Please help your users prior to forcing us to be Ex-users…

Kind regards,

1 Like

Hello, same problem here with a 4ch and come mini. The temporary on/off started a coule of days ago. Any firmware updates.

Why we should change network config???

Hello everyone.
I want to share with you my solution.
I was experiencing same problem after made a change in my network configuration. Indeed without apparent reason all sonoff devices started to turning off by themself.
When I had this problem my LAN was configurated as follow:

  • IP addresses 172.16.X.X
  • Mask
  • Gateway:
  • DHCP from to

I simply solved by changing my DHCP as follow:

  • DHCP from to

I hope it can be useful for somebody.

Hello Lui:

Your solution seems to be similar to the solution proposed by Eqwelink support of assigning a fixed IP in the range X.X.X.150 to X.X.X.255
The problem is that, since no one has any idea of what is going on, the problem could perfectly well happen again in the new IP range.

We really need to know the origing of the problem,or at least some idea of the reasson why this is happening.

Good luck Lui

Same here.I t’ve tried everything that mentioned and the issue still here
It’s a brand new powe320d and I didn’t know about this bug
No answers not anything from the ewelink
Definitely this will harm the reputation of the company
Last month dlink suddenly discontinued some series of smart plugs
These are not good news for cloud devices and you should prepared for the recycling bin

After some investigations I think that the problem is related with sharing the same SSID with 2.4G channels and 5G channels. We all know that ewelink devices are only capable of linking with 2.4G channels and when the same SSID transmits both fercuencies is when the problem appears, in my opinion.
I have no idea why some devices are more sensible than others to this problem but what I can confirm is that all the devices using an SSID that only transmits 2.4G frecuency work perfectly well.
Will it be possible that some of you try this solution to confirm that it works in all cases?
To do this I have enabled in the router the invitation SSID and link the problematic devices to this 2.4G only channel.

kind regards and Ewelink please do some work on this problem.

I’ve disabled the 5Ghz on my router and the problem hasn’t been resolved, I’ve solved only with the static IP configuration

You have to be sure that you disable all the 5G networks. The trick is in the “Band steering” possibility. It is not so simple to inhibit it in some routers. The 5G light could be off and still the band steering be on and trasnmitting the combined networks. Try the guest network and make sure that only uses 2.4G

What is sure, at least in my case, is that it is associated with lossing the conection to the network (Could be to a restart of the device).

My 5Ghz SSID has a different name. I didn’t changed anything in my network an the problem appeared suddenly. But it really seems to be a worldwide issue. What changed?

For me, the problem is in the eWelink side.

By now, for me, the only way to “solve it” is ip reservation but I still have more devices with the problem 'cause my router only allow me 8 mac reservations.

I completely agree with you that thi issue has to be solved by Ewelink, or at least they should give the Ewelink comunity an explanation of what is going on. They has refuse to do it and we have to basic options:

  • Throw to the waste basket all sonoff devices.
  • Investigate by ourselves possible solutions.

One possibility is that the problem is related with Echo. It appears that always Echo is active in the networks where the problem is happening.

The issues that we need to understand are:

  • Why the devices are restarting and therefore going to the predefine power up state (normally off)?

  • Why the fix IP is helping the problem?

  • Why the problem suddenly appears, without any apparent reasson, and why it goes away for some days, also without any known reasson?

Please try something and report your findings.

Do not forget to keep pushing Ewelink in any way you can imagine to say something about the problem.

Good luck for all of us.