Zigbee Turbo Mode

Hey there,
What is the downside of using Turbo Mode full time?
I assume that since it’s disabled by default and good range is always welcome, it could be dangerous for the chip in the long term, right?

There is no impact on the device. But in order to meet the radio certification standards of some countries, the normal factory equipment will reduce the transmission power to a relatively low range - which will result in a smaller signal coverage, and of course it will avoid interference with other equipment, so as to meet radio regulations around the world.

If you manually turn on Turbo mode, the radio power is adjusted to the maximum - this is the limit of the signal can be transmitted and covered, but in some countries and regions, such RF signal strength is more than required by law - although in most cases it is not perceived by anyone. This feature is provided for advanced users who wish to have higher transmission power and who confirm that it complies with their local regulations.

1 Like

In most cases, this accomplishes nothing, as the 2.4 GHz frequency is overcrowded. Switching turbo mode on increases radio noise especially in locations with multiple WiFi networks. Using this option only makes sense where there is no radio congestion nearby. Otherwise, it can make the situation worse. A much better solution is to use routers that pass data on to other devices. These types of Zigbee products are typically mains-powered so they are always available on the network. Good planning is important because Zigbee is a low-power wireless mesh network.

1 Like

The layout of my flat is elongated, with a considerable distance between the bedroom and the entrance. iHost is in the very inside of the bedroom, I only have end devices - sensors, and it works great with this option on.

On the flip side, my IKEA gateway sucks, despite having at least four routers across the rooms.

ps: I love using devices with their branded gateway to get most of the features and use Matter Bridge to get them mounted to other platforms.

With Home Assistant, you can have everything together and build a Zigbee network without any problems. I have dozens of Zigbee devices. Among them Ikea (including roller shades, sensors, lights), Sonoff (sensors, remotes, plugs), several from Aqara and various brands (Tuya platforms). in addition to Zigbee, there are WiFi devices from Sonoff and Xiaomi (with manufacturers’ firmware). All of them managed to be combined into one system, automated within HA and hooked up to a voice assistant. NSPanel Pro and NSPanel are only partially integrated, because full integration requires changes to the firmware of both panels and this means the Sonoff warranty is lost.
I would not want to return to iHost under any circumstances. That device went to a friend whom I somehow don’t particularly like :laughing:

1 Like


Ok, thank you for your time.
One last question now that we are talking about sinal coverage :slight_smile:
I’ve got a SONOFF Zigbee 3.0 USB Dongle Plus here and I’d like to know if I can use it on the iHost USB port to get a better signal transmission?

Thanks in advance.

You can flash a router firmware and use it to extend coverage rather than transmission increase.

Here’s a guide from Sonoff:


1 Like

As @ward mentioned, this does not make much sense. The thing is, it’s not the signal strength but the signal quality that is crucial. A better approach is to use devices that are routers. Their judicious deployment can do a lot because Zigbee networks are self healing mesh-type.
Check out this study. Watch this video. This one you may also find helpful.
Consider that despite your efforts and endeavours, you will not achieve the expected result. The 2.4GHz frequency on which Zigbee operates is impossibly crowded in many locations. It’s as if there are many people in one room trying to outshout each other.

1 Like

Great explanation, thank you very much!
I’ll look into the material you provided.

Hi there!
After struggling with some errors, I installed a router firmware, but iHost is telling me that it is not yet compatible. Is this right?


plz turn off your Zigbee2Cube addon and try again;

Hello, thank you for your reply.
Unfortunately, when I turn Zigbee2Cube off, the dongle won’t pair with iHost. It doesn’t find anything.

He meant “turn it off and on again” :slight_smile:

You need to make it enter pair mode again.

The physical buttons is inside the case of that dongle; if you don’t want to open it up, reflashing the firmware would put it into pair mode again.

And thx jam3 for the rewording

Yes, I have opened the case, no problem here. And I tried pairing with the add on disabled. It will not pair in any way.
After enabling the addon, pressing the button, the scan takes about 30 seconds to find without issues.
The problem is that it says that it’s not yet compatible, as I mentioned.

Can u plz take a look of your Zigbee map, is it already a router there? Cause it is just a router, no other controls are needed.

It’s just that some devices keep getting offline and I wanted to extend the range to see if it works better.

Please send us your log from the iHost WebUI, if that’s too large, feel free to use cloud storage like Google Drive to share with us.

Thx for your time.

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.