Winter time --> Summer time - same problem every year

Like every year, at this year ewelink also failed to manage the devices to switch precisely from winter to summer time (and usually, the same happens when we have to switch back). The problem has always been that the switch (add or decrease one hour) happened too late, but this time, just 2 days before the actual change, all devices managed to switch. It’s about time to fix this error, because during 2 weeks around the clock changes, the devices are unusable! I write a feedback every year when this happens, but nothing changed. If there’s a time switching (from winter to summer or the oposite), every year I have to shut down all of the devices for ~1-2 weeks, untill they can get the right time. As I wrote this year one thing is different, they switched too early, so I only have to shut them down for 2 days…


On this issue, the folks at eWeLink are unreformable. Sooner the European Parliament will finally vote to abandon summer time, which will probably happen this year. The problem will go away on its own, as long as they at eWeLink notice the change :tipping_hand_man:


New experience today: the programs now running one hour later than the times what I set for the programs… It is getting worse…

1 Like

Same problem here on Atlantic Daylight Time. Used to record usage data to spreadsheet at midnight, now have to wait until 1am.

1 Like

I found this post on the website Editing your timers back or forward simultaneously - eWeLink

Really frustrated, two times every year.

1 Like

Hey @kodonci @imaddicted2u

Apologies for any inconvenience you’ve experienced. As @HeisenBerg kindly mentioned, the eWeLink app provides a feature that allows you to edit timers and schedule scenes in batches.

To guide you through the editing process, here’s a video that should be of better assistance.

I’m using 4 sonoff S40TBP smart plugs with energy measurement.
Here are 2 screenshots, one taken after 12am the other taken after 1am. Note the bar graph shifts right after 12am (12:41am) and the today run time is showing 23h41min when it should be 00h41min… The device or ewlink time is stuck on Atlantic Standard time after the switch to Atlantic Standard time.
The other pic shows shows the bar graph shifted back to left, back to normal after 1am (1:11am) and the Today run time is 11min even though my time is 1:11am, so, the Today run time should be 1h11min.

I’m have another issue that’s unresolved where the data for all 4 of my got scrambled and the yearly bar graph now shows data from before I got them on December 2, 2023 on all 4 devices. This seems to have happened due to the leap year. Attaching a screenshot of that.

I discovered yet another issue when the month changed from March to April, since I can’t scroll back the bar graph months, I have to download all the csv files to get the data for the last day of the month. The first csv file is correct, the csv files downloaded for the other 3 devices are messed up.
See this thread for more details.

Thanks for the link, but the problems with this:
-I have 23 automatic scenes, none of them appears on this list.
-If my scenes appears there (but they doesn’t), if I adjust the time, they totally mess up. I tried to do this last time when we had to change the time from summer to winter, but it not helped the whole situation unfortunatelly.

So as I see, the best that I can do, to wait if the server’s(?) clock gets the right time…

Hey @Daniel_Zhan

Do you mind checking this issue? Thx in advance

1 Like

Sorry, typo’d this line
The device or ewlink time is stuck on Atlantic Standard time after the switch to Atlantic Standard time.
Should read…
The device or ewlink time is stuck on Atlantic Standard time after the switch to Atlantic Daylight time.

I have found an easy solution for when the clocks change.
All you have to do is turn off and on OR on and off each scene after the clocks change. They then all work at the correct new time.

1 Like

Thanks, I will try it next time. :smiley:

I have 10 TRVZB devices and the Smart Scheduled times with temperature are also shifted, I won’t redo the times for all of them. I also tried to change the Time Zone from Central European Standard Time (Prague) +1 to Etc/GMT-2 (GMT+2), which should solve the daylight saving, but it is useless. Everything is still an hour late.
So why is Time Zone on the menu at all? Why can’t you set an offset for daylight saving time and standard time (winter time), and then the APP wouldn’t have to move the other times at all. So to this day I still don’t know why the device actually shifts the times, if I want the device to start at say 10 o’clock, it doesn’t matter if it’s daylight saving time or winter time, it should still start at 10, it’s just that switching to another time shifts that time nonsensically and has to be manually reset to the correct value.

I have an automatic scene
Trigger 1) time
and. 2) temperature from TH
Action: send push notification

It’s set for 2355 GMT but I get it now at 0055 BST. I think it is only since summer time started.

I have the same problem. I have 6 TRVs and all the schedules are shifted by one hour. I tried changeing the timezone, redoing the schedule. Nothing seems to work. This issue stared since the DST.
Is there any solution to this ?

I have the same problem. The bulk timer function also does not work (iOS-App), as it often does not show any parameters and when it sometimes does, I have no possibility to change the time schedules of my TRVs. That is really anoing!