Tried to upgrade, however some other software loaded too

So i tried to upgrade to the Advanced package, however I got another application which loaded and I cannot upgrade to the advanced Plan
if I can get some guidance to uninstall and setup the new plan.

I can’t understand what exactly is happening…

Good day

I tried to register and use the Advanced Plan.

I downloaded the application in another language and since then, cannot confirm to upgrade to the Advanced Plan after

It was set to English however its now in Chinese, need some assistance to remove and reload the application and make payment

regards
Brad

Which exact application did you download?

The only official application is eWeLink. Here are the addresses to the sources where you can download the applications.

Activation of the advanced plan takes place here, you enter the e-mail address of your account you created in ewelink.
https://vip.ewelink.cc/

Uninstall the applications and reinstall from a reliable source!

Hi There

Please can you send the link for my Windows 11 devices, I have it on my mobile already, trying to resolve on my Notebook

Thanks
Brad

Hi there, the eWeLink app cannot run on PC.

The eWeLink application does not exist in a PC version (Windows/Linux/x86)!

You can use the WEB version through a web browser if you have purchased an advanced plan.
https://web.ewelink.cc

Another option is to run an Android emulator on your PC and run the eWeLink app for Android there.