Tile2CUBE-Weatherapi not connected

I spent the whole 14 day trial period of the weather api waiting for a forcast that never came in, i always got an error every time it tried to connect, has anybody in the US been able to get it to work? I was having issues with my internet at the time so I can’t say if that was the issue or not.

did you use vpn? if you did please disable it , the weather add-on use domain for service, and please make sure you can access ihost with the domain ihost.local

Mine also never worked but I changed the location to the first Chinese city I thought of (Shanghai) and back to London and it started working.

http://ihost.local/cast doesn’t work for me, I get the error this site can’t be reached

Eerke; I will check this out and see if it works for me, thanks.

Mine disconnected again, so I deleted it and reinstalled it saying Shanghai. Will see how long it works this time if I don’t change it.

Node Red also completely stopped working. Reinstalled that aswell. Before it broke in Web UI but I could access remotely. Now both broke. Luckily it can be backed up. Made me wonder is there any way to back-up Zigbee settings and scenes on the iHost? Much of it could not be backed up but Zigbee pairing and scenes takes ages.