TH elite, extension lead Problem

Hi All. Im having a problem with the TH elite extension lead. I am using it to monitor a hot tank which can reach up to 80deg c. without the extension lead the readings are ok but when i connect (extension lead) to the TH elite it stops showing the temperature after about 38 deg.
The only thing i can think off is that the extension lead resistance is too high for the unit to operate above 38+ deg c. I will reduce the length of the extension lead and see if it makes a difference but any suggestions from anyone would be great. Many Thanks for reading, Trev

Yeah I’m pretty much convinced that the extensions don’t work at all the pretty much useless. I had to rewire my whole system because they marketed these things I bought them in their utter garbage

I’m away at the moment but I will let you now if I get a fix. It’s a shame because for the price it’s a good product.

Loops @Daniel_Zhan from SONOFF team for deeper dig.

I use the products for spa and pool controls. Lots of money invested in these items and would pay more for better quality. Yesterday I rewired my whole config and confirmed that they do not work reliably with extensions. They work correctly without. However the auto settings do not work form android. Had to borrow an iPad install ewelink and got them to work. Support confirmed the issue and I’ve been waiting for weeks for a new android build. Needless to say this is not the level of quality one expects.

I also find it madding that they say they support amazon Alexa however they have done a really poor job on the API side. On off and temp readings are separate and no auto config from Alexa at all and force to use the sub par eWeLink app.

With there was an alternate product out there.

1 Like

Hi , I reduced the extension lead to 1m 20cm (just enough to reach my solar hot tank) and it has worked ok for the last 24 hrs. The tank reached 85c and the th elite has worked ok. I am using it on Android and the ewelink web dashboard with out any problems. I can ask Alexa “what’s the hot tank temperature” or say “Turn on Hot tank” which switches on a pump and it also works ok. I have about 14 sonoff devices all working ok with Alexa. I did have problems using a TalkTalk router until I added a TP LiNK extender which had a much wider range of Wi-Fi channels. I haven’t tried the auto setting on the TH but I set the push notification at 50c and that works ok. Hope you get it sorted.

1 Like

Did you spice into the extension or use a phone crimping tool? did you determine the optimal length or just found that this is what you needed and works?

I would like the ability to set temperatures via Alexa. that does not appear to be possible.

The bug I am referring to is the ability to set auto temperatures on the android device. There is no benefit to setting the Spa or Pool on and off via Alexa. There would be benefit in the ability to set the temperatures, just like nest thermostats and others. Simply code to implement but they have not done it. Presume it’s to drive people to use the lack luster ewelink app.

I just spliced it (soldered) , I cut it to the minimum length I could get away with and it works ok. Have you tried Home assistant. I have tried it but It’s abit too advanced for me. There’s an add-on for sonoff / ewelink .

UPDATE. Reducing the length of the extension cable has solved my problem . The TH elite has worked perfectly over the last month.
Hope this helps anyone with the same problem. Using the 5m extension cable it kept losing its temp reading above 40c but after reducing the extension to 1.2m it works ok. It would be nice if a firmware upgrade could sort this out ?


Same problem with 2 TH Elite, 2 extension cable and 2 dallas. no data on th elite after short time usage.
I need 2.8m of extension cable so i’ll try to cut and reduce lenght to solve.
thanks for sharing information.

1 Like

Hi Bart, Hope it solves your problem. Mine is still working fine. i have it monitoring a hot tank that reaches over 80c . I imagine someone just monitoring a room might never notice its a problem.

1 Like

Hello, i have the same issue, my solar water heater is on the roof top while the th elite is installed inside the house. I tried to get 3x extension cabels but it is not working, i tried to create my 15 meter extension cable using an ethernet cable but still not working, it only works when connecting the sensor directly.
Use a shorter cable is not a solution as this is the needed distance between the th elite and water heater. I desined my setup after checking the specs with a note that the sensor can be installed 60m away
I think this issue has to be solved, not sure if by firmwear update of if the devices are defected


I wonder about replacing the wire with shielded heavier gage wire would help. Personally i find this horribly misleading and the company has done nothing about it

I tried to create a custom cable using a cat6 stp cable, but same result, not working!

Similar problem here, but the opposite: when temperature from the hot tank falls below ~44 celsius, it stops reading. I have only two 5m extensions to be able to connect the DS18B20 sensor to the Sonoff th16 elite in a room where I can see it. Sonoff/sensor marketing says 60m would still work, but this is not the case indeed.

I have same problem with extending 15 mt ds18b20 sensor . Used original extend or making custom wire both didnt work,no data.

Did anybody fixed issue?