Sonoff ZB firmware

What’s wrong?

Frimweare ZBMINI L2 markings are marked with a blue rectangle.

As you can see, in two places the firmware is 1.0.10, while in one it is 0.0, why?

Frimweare ZBMINIR2 markings are marked with an orange rectangle.

Why is the firmware label 0.0?

Why is the frimweare label on the SNZB-2P 2.0 in one place and empty in the other?

I note that all devices were purchased together from the same seller and put into operation on the same day!

I think it is necessary to harmonize the frimweare versions!

In the first sccreenshot the device with firmwar 0.0 is marked as offline

what software you’re using, because we don’t know what the logic is for the software you’re using to search for the firmware version, and whether that part of the code works correctly.

If you have a problem with the firmware version display in the eWeLink app, we can help you deal with this issue, but if in other software or platform - I’m sorry, we don’t know why, because we didn’t develop that software.

This screens is provided by

The firmware for Sonoff ZBMiniR2 is not displayed in the eWeLink application

While for the Sonoff SNZB-2P, but only for one device, it does not return the firmware version

Also, the eWeLink application for ZBMini L-2 does not provide any firmware information

Based on this, I suggest that all the attributes of Sonoff Zigbee devices be considered in detail and, if possible, perform unification for all devices and enable users to access them (for example: updating freamware, inching setting, trigger setting…)

1 Like

I personally had a problem with the singular ZBMini L2, which was in Pulse mode.

With the help of friends on eWeLink & Sonoff User Group on Facebook, I solved it in the following way:

“Short press the button 3 times until the green LED blinks 3 times quickly to change to edge mode.”

It’s good that I solved the problem, but I think that it shouldn’t work like that, but for me, as a user, there must be an option to set up ZBMini L2

1 Like

In the App, it is required to provide the user with the option to switch input modes - just like the WiFi version of the Mini. If you can’t find this option in the app, that’s a problem and we need to fix it.

We’ll check to see what’s going on, including the firmware version number you mentioned on the web.

Here is information that can help you:

On the SNZB-2P where the firmware label is in the blue rectangle, the eWeLink application and eWeLink Web see the firmware label without any problems

While the SNZB-2P, where the firmware label is marked with an orange rectangle, the eWeLink application and eWeLink Web do not see the firmware label

I solved the problem with firmware ZbMini-l2 :innocent:.

I logged out the device from the eWeLink application, switched it to Pulse mode and registered it with the application and the firmware information appeared…I logged out the device again from the eWeLink application, switched it to Edge mode and all the firmware information is present, and the device does not go to offline…

I hope this can be of help too!