Sonoff SNZB-01 reverse not working?

When trying to control a light using the Sonoff SNZB-01 with the Sonoff Basic R2 smart switch I’ve set the light up as ‘reverse’ as opposed to ‘on’ or ‘off’. I assumed this will act as a toggle and reverse what ever the status was.
The problem I’ve found is that it won’t ‘reverse’.

As an example.
The switch is unresponsive to my first click. If I double click the switch first, then click once……the light comes on.
To turn it off, I have to double click the switch again, then a single click, and only then will it turn off.

I have 4 of these switches and they all have exactly the same issue.

My question is, why won’t the light simply reverse its status when I press it once as it’s been setup to do?

Thanks in advance for any pointers.

1 Like

i observed the same issue

1 Like

I have two old scenes that change the status of the lamp when clicked once. But when I resave these scenes with the eWeLink App v4.31.0, the scene behaves exactly as you described. So the error is probably in the App.

Let me check and get back to you guys.

Fixed, please try again and let me know.

mine is still not fixed…

update: i just fixed it after editing the scene (didnt do any changes), and re-saving it…