Sonoff iHost device itself firmware upgrade

Hi All,

I’ve recently purchased a new Sonoff iHost device (Hub\Bridge) and i’m interesting in firmware upgrade.

My device had V1.3 and ive notice v1.10 is available with advanced features.
Nowhere online i could find how to perform the firmware upgrade.

Im not interesting in end-devices such as switches or remotes im specifically interesting in the iHost hub itself!

Thank you!

Go to the iHost settings page and look for “Link eWeLink Account”. Once you have done that, the iHost will show in the eWeLink App on your smartphone. There you can go to “device settings” and update the firmware.

As far as I know, this is still the way to do the upgrade over the air.

iHost Version Updates Information & FAQ - SONOFF Official

Hi, you need to login to your eWeLink account to get the OTA, please go to settings page to link your eWeLink account, once logged in, the new firmware will be pushed to your iHost (you need to manually click the update button)

Thank you for the prompt respond!

I remember to had this option in iHost settings before the advanced plan upgrade, it seems its not available anymore:

Thank you

Hi Teki. After doing a hard reset of ihost, I no longer see the “Link ewelink account” setting. In the ewelink app I no longer see ihost. Is there a solution for me? Thanks in advance.

@Newbee @liberaccio The account binding feature has been removed, now you don’t need to login to your eWeLink account, you can still get update push.

1 Like

Perfect. Thank you for your kind feedback.
Regards and happy new year :clinking_glasses:

Hi Teki. Is there a way to update the firmware of the devices connected to the ihost (LAN or zigbee)?

1 Like

Hi, Is there a way to force upgrade push?
Im.stuck in 1.13, i reboot and wanted as suggested in the main update thread, i reset ihost with mo luck. I also open a ticket. Waiting … :crossed_fingers:

I’m piggybacking on the question. Will Ihost support OTA updates for slave devices.

Hi New iHost users, I bought one recently and it came with firmware 1.6.3 but stuck to that. When I tried to link it never succeeded nor I was able to install anything to docker. It turned out to be my Unifi security was blocking the two IP connections to the iHost. So if this happens to you please check and ask the security setting to notify then you can judge and allow any such connections. But I want Sonoff to make sure they white list their IP with major vendors or publish the domains that needed to be allowed so that we can put them in white lists.

Hope this helps someone.

@Teki I don’t see any update options in the settings. I have 13.0 and I don’t see any update button for 13.2. Is there anything I can check?

@liberaccio hi, at least your not alone. same here. in another post they said that ihost perform an upgrade check every day at 12pm.

Hi Salvo. Thanks for the feed. I was hoping to be able to install 13.2 today, since I’m doing yet another hard reset due to the problem of device matters disappearing.

@Teki Is there a way to force the update? I would like to avoid having to redo the entire configuration again in the next few days.

1 Like

Hi @liberaccio It more than likely this feature came with 13.2 I do see the option to check for update next the version on the settings page.

Hi @kuru.kanagalingam .
If you are talking about the system update, they said that 1.13.0 also included the stand alone update option (not from the ewelink app). The problem is that it doesn’t appear no options for me.

Hi @liberaccio Yes I am talking about system update but I only moved from 1.6.3 to latest few days ago. So don’t know if this was there before or been on 1.13 but I have
Device Info
eWeLink CUBE Version 1.13.2 Check for update >>

Do you see this Check for update on your iHost.local setting page? Other reason to believe it may be introduced or fixed in version 1.13.2 they do say this version firmware optimisation The Probelem I had before was my Unify UDM was blocking the iHost reaching Sonoff servers I had to white list those rules to get the update.

Hi @Newbee, I do believe only after 1.13.2 you will be able to directly update from iHost.local by clicking the

Device Info
eWeLink CUBE Version 1.13.2 Check for update >>

But do check your loal firewall rules as I had Unify UDM and it was blocking my iHoast reaching the SonOff Servers I had to change the setting from notify and block to Notify then I was able to allow this fixed the issue of updating. Now hopefully if works better since I have a clickable option to check for new updates.

I’ll try to decrease firewall protection on my router.
Thanks for suggestion.