Reflash your iHost with your own Linux distribution

default login:
username root
password aibridge
see the pic I added

Thanks, not sure how I missed that!

Hey! So I tried flashing Linux on the ihost. I turned maskrom mode on (green flashing light) downloaded all the drivers after that I opened the flash tool and I put in the Linux for ihost image. There are two variants on the forum for flashing I first used the Chinese version because I didn’t saw the other one until later. The chine version failed flashing and now the lights are red. After that I discovered the English and newer version of the flash tool but it wouldn’t want to go into maskrom mode. After a bit of thinkering it’s in maskrom mode but it keeps failing to flash or do anything whatsoever ( see attached picture). Can someone please help me with this? Thanks
Schermafbeelding 2023-07-13 231208|690x355

Darn. I haven’t tried flashing it yet, because I still have hope that at least with access to the USB port, I will be able to fully use the iHost for Home Assistant (with full access for Zigbee Home Assistant (ZHA)).
@JordanWise - Do you know if there is any newer version out there?
Thanks and cheers

i have flashed, how i can install hassios? dpkg and apt not found

Any luck, @malwar ?

It does not support dpkg…

If you want to install home assistance on this linux os, you can do so through python. Of course, you can also install HA core through docker.

1 Like

Thanks @Alexie
Will the HA installation have access to the onboard Zigbee controller?

I got enough tilting at windmills so disconnectet iHost and flashed my old amlogic TV Box with armbian (on SD card), then Python and Home Assistant core. It works great. Very stable and power consumbtion is 1.52 Watt with running HA and zigbe dongle connected (ZHA).
First of all I don’t think it is possible to give HA access to zigbee coordinator on iHost. You can do that only with your own linux flashed on iHost, but it’ll take at least a year.
But there is one improvementon iHost. Look at attached picture

Unfortunately it is only replacement solution but you can use zigbee dongle in HA on iHost in ZHA mode.
I suggest to read this forum:

1 Like

Thank you for your information. I took a quick look at your retweet and, as Tim L mentioned, if you’re familiar with both HAOS and building a linux distro, there’s not much difficulty in porting HAOS to ihost.

If you are having trouble building your own distro, you can contact us here and we will help you in the best possible way.

1 Like

then once the flash is done
log in with ssh
ssh root@ihost.local
pswd aibridge

docker volume create portainer_data
docker run -d -p 8000:8000 -p 9443:9443 --name portainer --restart=always -v /var/run/docker.sock:/var/run/docker.sock -v portainer_data:/data portainer/portainer-ce:latest

log in to portainer https://ihost.local:8443
enter your credentials.
go to stacks - add stacks

copy the following

version: “3.7”
container_name: homeassistant
image: “
- /root/hassio/config:/config
- /etc/localtime:/etc/localtime:ro
- /run/dbus:/run/dbus:ro
- /dev:/dev:ro
restart: unless-stopped
- “/dev/ttyS0:/dev/ttyS0”
- “/dev/ttyS3:/dev/ttyS3”
- “/dev/ttyS4:/dev/ttyS4”
- “/dev/ttyFIQ0:/dev/ttyFIQ0”
privileged: true
network_mode: host
container_name: configurator
image: causticlab/hass-configurator-docker:latest
restart: always
network_mode: host
- “com.centurylinklabs.watchtower.enable=true” # for Watchtower automatic updates
- “3218:3218/tcp”
- /root/hassio/config/:/config # map this volume to your hassio config directory
- HC_BASEPATH=/config
container_name: esphome
image: Package esphome · GitHub
- /root/esphome:/config
- /etc/localtime:/etc/localtime:ro
restart: always
privileged: true
container_name: tailscale
image: tailscale/tailscale
restart: unless-stopped
- /var/lib:/var/lib
- /dev/net/tun:/dev/net/tun
#- $ {DOCKERFOLDER}/Tailscale/var/lib:/var/lib:rw
privileged: true
network_mode: host
#- $ {DOCKERFOLDER}/Enviroement.env
# - $ {DNS}
- TS_EXTRA_ARGS=–advertise-exit-node
- TS_AUTHKEY=tskey-auth-

press on action button

this is my disk situation

Filesystem Size Used Avail Use% Mounted on
/dev/root 7.3G 3.8G 3.2G 55% /
devtmpfs 873M 0 873M 0% /dev
tmpfs 874M 0 874M 0% /dev/shm
tmpfs 874M 348K 873M 1% /tmp
tmpfs 874M 336K 873M 1% /run
cgroup 874M 0 874M 0% /sys/fs/cgroup
overlay 7.3G 3.8G 3.2G 55% /var/lib/docker/overlay2/d067fcd82043db4fd0e6fe6112e148a7a06337c42dc2b1227604bc759b3b1308/merged
overlay 7.3G 3.8G 3.2G 55% /var/lib/docker/overlay2/52d6ab5187382316d4785dab61880da7db3367df7ef9b9dfe55330487e1ab9b2/merged
overlay 7.3G 3.8G 3.2G 55% /var/lib/docker/overlay2/3bee5798110d95c372b86eb38683dcbe01491ac97382302ec00afe7a87a2bc8b/merged
overlay 7.3G 3.8G 3.2G 55% /var/lib/docker/overlay2/4c8d82bfc6708182552ea64d61cd0c498f892559a39e98ddd23398e2cdddc09c/merged

I tried to mount the sdcard to the docker overlay folder but at startup it doesn’t always start despite being inserted in fstab. does anyone know how to tell docker that its folder is somewhere else?

1 Like

Firstly, stop your dockerd:
/etc/init.d/S60dockerd stop

make sure your sdcard is in ext4 format,and mount on rootfs:
mount -t ext4 /dev/mmcblk2p1 /mnt/sdcard

and then mount your sdcard dir to docker workspace:
mount --bind /your/sdcard/path/to/dockerd /var/lib/docker/
mount --bind /your/sdcard/path/to/containerd /etc/docker/

finally, restart dockerd:
/etc/init.d/S60dockerd restart


edit /etc/init.d/S60dockerd to chang root dir, locate at DAEMON_ARGS Options and fill in:


for me work only bluetooth with hassio.
zigbee no
wifi no
button no

there is a solutions?

1 Like

Zigbee works, just put /dev/ttyS4 in ZHA setup (baudrate is 115200) .
Wifi - probably not
Buttons (and LEDs) will require a custom HA integration to work

1 Like

Both WiFi and BLE can be implemented using the RTL8723 module - the driver for this module should already be installed on this image.

1 Like

hello it would be nice if you described in video the steps for novices who want to try to install homeassistant supervisor

Not there quite yet. :grin:
But the pieces are forming. And I believe that once it is possible, sales for the iHost will go up with the enormous user base Home Assistant has. Sonoff has in the past done well with keeping the door open to the community. Thanks for that.

I myself for instance have several NSPro Panels. Two with the original software and two running on a different environment. Without that option I only would have bought one (if at all).

It is not possible to run supervisor on this Image, you can only run HA Docker.

I am one kernel away from having an initial build of HAOS though.

1 Like

for the YC1175 MCU chip is there a datasheet or a way to control it from serial? this should control the leds. how can I do? I only understood that it is on uart3.

Zigbee works great.
To mount the SD card, unfortunately it happens that at startup it doesn’t always mount it automatically, not even with fstab. maybe some service interferes with the mounting

thanks u

1 Like

RK1109 and YC1175 serial communication commands.pdf (1.0 MB)

1 Like