No devices in eWeLink add-on on iHost

I installed eWeLink Smart Home on my iHost and logged into the account. The iHost is linked to the account and appears in the app, but there are no devices in the eWelink add-on on the iHost.

I tried uninstalling and reinstalling but there are still no devices.
The devices appear when I log into the eWeLink web account directly via the browser with the same account details.

Any ideas what I’m doing wrong?

Instead of syncing devices under your account, the addon just searches for supported devices on your local LAN after logging in.

So please confirm the following:

1 What type of device is it? Whether it is within the models supported by the current Addon. Support List Here

2 Check whether the LAN mode is enabled on the device.

3 Check whether the device and iHost are on the same LAN - You can log in to your router to check whether their IP addresses are on the same network segment

I have been having the same problem and came across this reply. I will post my questions on each point.

  1. Does the add-on allow only WiFi devices which are linked to eWeLink to be fetched into iHost? I am trying to do this with ZigBee devices i.e. temperature/humidity sensors.
  2. Can you please elaborate on this?

for now the eWeLink Smart Home add-on supports WiFi devices with ‘LAN control’ feature, WiFi devices without ‘LAN control’ feature will be supported soon. Zigbee devices can be added to iHost directly, or added to other Zigbee gateway like ZBBridge-Pro and then be synced to iHost via the add-on

1 Like

Thank you.
Will the sync work with Zigbee devices linked to the ZBBridge (non Pro) ?

No, should be ZB Bridge Pro.

1 Like

Understood. Thanks.