MQTT-eclipse installation issue

Hi Everyone,

I try to install Mosquitto-eclipse.
Firstly, I installed filebrowser:
I installed eclipse-mosquitto:

In home Assistant, I try to install MQTT:
but the answer is:

What is wrong? Could anybody help me?

Thank you,
Best regards,


I take it that is the IP of your iHost and it is static.
Also nothing else you’ve installed uses the port 1889?

Where’s the host of your HA?

If that’s also on your iHost, maybe you should try localhost or internal IP allocated by Docker

Yes, nothing else uses the port 1889.

I also tried with localhost and internal IP but nothing works.

I don’t use HA so no idea there, but my Mosquitto runs with Node-red and Tasmota following this guide, using the config file.

Maybe you’ve already done this, but just in case.
Unfortunately my Smartthings MQTT driver can’t subscribe to a port which is not 1883, but for running MQTT from iHost it performs OK.

Did you modify the mosquito.conf file to add the 2 lines :
listener 1883
allow_anonymous true

1 Like

I’ve deleted the Mosquito Broker docker on my iHost now but did check it worked. Can’t check now but from memory that was the port. I have a broker on my RP4/Home-Assistant: you just need to create a local only user for MQTT clients to log in but I can confirm current HA Operating system and current iHost work with Mosquito Broker Add On in Home Assistant as that is my current setup. In theory I think you can create a log in for each MQTT client but I got bored doing that. I don’t know why your iHost broker doesn’t work: it did for me with a very similar setup. Maybe something to do with an iHost firmware update. It was quite a while ago I tested it.

yes, I created moquitto.conf with the 2 lines.

Finally, I found the mistake:
It works with the folder below:




thanks all for your help.

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.