Installation of v1.4.3 on Homeassistant 2024 failed

The addon was working fine, until recently (last week), it showed it’s not loaded correctly, so I tried to reload but failed.

Then, I try to upgrade but failed too. So, I tried to uninstall it, then installing again and found out the error below:

Failed to install add-on

The command ‘/bin/sh -c npm install --production --save-exact’ returned a non-zero code: 1

I’ve even tried to upgrade to the latest HA core as below but doesn’t work too:

  • Core2024.5.1
  • Supervisor2024.04.4
  • Operating System12.2
  • Frontend20240501.0

does anyone know?

What kind of add-on installation on iHost is it?

do you mean installing HA on iHost docker?
btw the latest CUBE version is 1.14.0

I’m installing on HomeAssistant RasPi4

I had it working for long time till end of March’24 when it’s not loaded in HA. Then I tried to re-install and I got this error. I tried to remove and add the repository again but has no luck installing it anymore. Any clue??

No clues at all. Could be many reasons. Use the Raspberry Pi Imager.
As an aside, you chose the wrong forum. HA and RPI issues are not discussed on this one.