How to add a countdown timer to a lamp

Hi everyone, I’m looking for a solution to set up an automatic system to switch off a lamp automatically after a countdown…
I’ve tried through the scenes but when we fill in our condision (If lamp 1 is on ) we can’t find “lamp1” in the “then” part so it’s impossible to tell it to turn off after a countdown … if someone could help me with this simple feature. thank you in advance for your help.

How about using inching? Is this option valid for your lamp?

Jam3’s answer is more elegant. If your device does not support this, you can use Light state changes as a trigger for a delay toggle

I don’t know where i can see this parameters. For the moment I just see iHost, and MINI L4 device but there are no option like “inching” or “light state” .
I think I’ll have no choice but to use another system like nodered or another docker, what do you think?

Why so hurry? :grin:
Tell us more about your lamp and its relation to iHost. How do you control it? Is the lamp connected to MINI L4? And MINI L4 is bound to eWeLink app, right?

Haha I’m just hopless.
But yes my conf if a lamp MINI L4 connected to Ihost, but directly managed by Ihost.(I’m not sur about eWelink, beceause for me eWelink is still a other system no?)
I manage my lamp on my Iphone to, with the Homebridge docker.

There’s no MINI L4 in Sonoff’s offer. Isn’t it MINIR4? If it is, it cannot be directly connected to iHost since it is a WiFi device.

iHost is a device. eWeLink is a system supplier.

What is your lamp connected to, after all?

You’re right, I made a mistake, I have a mini L2 to pilot my lamp, connected by Zigbee to my iHost.

It’s ZBMINI-L2.
If there is no “inching” option on the ZBMINI-L2 card, the delay to off setting will not be possible. That’s the beauty of eWeLink :tipping_hand_man:

:thinking:
It’s really annoying, I hope they’ll develop this feature because it’s still very useful on a lamp. In any case, thank you very much for your support.

Not sure why automation of the type “if [Device A] on → delay [xx] → then [Device A] off” isn’t possible. One of the many eWeLink oddities. This has been the case for many months. So, one can be hopeful but without exaggeration :grin:

If this is to be an action to turn off the LED device after the time has elapsed when the same device is turned on…

Self-deactivation can be achieved using the Timer for the device without the need for scenes.

Or with two scenes…

s2

If you’re still looking for a solution, let me know and I’ll try to scratch my head…