Help For eWeLink Camera Gateway

I. Installation

➢Install Docker on different operating systems (This tutorial is run on Raspberry Pi as an example). How to install a Docker can take this tutorial as reference: Runnable Docker Guides | Articles to help those who use Docker for Java, Rails, PHP, Python, and Node development.

➢Visit Docker Hub(, search “Coolkitmobile”, copy the Docker Pull Command.

*You can access to this image>>Docker Hub

➢Open a command line window, paste the copied docker pull command or just type “docker pull coolkitmobile/mediagate:latest” manually.

*Tips: If you are prompted with incorrect username or password, please log in to your docker account first, and type in the command line window: docker login -u username -p password.

➢Type this command line in the command line window "docker run --privileged=true --network host -v ${yourFileDirection}:/mg/dist/data -d coolkitmobile/mediagate"

Now the gateway container is working!


Now you’ve installed the eWeLink camera gateway, let’s dive into the settings part.

➢On any device in the same LAN, access cameragateway.local:8606 through a browser or directly access tbe IP address:8606 (Refer to the IP address shown in the command window of Docker)


➢Log in successfully, access the page of the camera gateway. It will automatically search for cameras, you need to click the camera that is automatically found and enter the camera information. Or you can also click the add camera button in the upper right corner to add camera.

*It will be displayed on the device list after a successful addition as follows.

➢The camera gateway and added cameras are visible in the eWeLink App as an icon as follows.

➢Click the camera to start the monitoring.

Hello, my Gateway is runnig with black screen and sound.
I think the error is here:

Help me to find it. It is my first raspberry project, sorry

you need to specified real file path string like /tmp/mg from your raspberry to replace ${yourFileDirection} string

How do I find out the path? unfortunately I have no knowledge about Raspberry.

any path is ok , it is just a path where the docker will save data to , it is not limited.

OMG embarrassing…
I’ve been desperately looking for the path.
Many Thanks

It is not easy to setup first, i am glad to help, if it was still unable to work , pls let me kown.

Hi Jimmy,
I think the tutorial is not clearly enough for users, would you please add more details in next version? Suppose it’s along with the optimization you guys are working on.

I’m also trying to use the ewelink camera gateway to use in the echo show. I can see the camera image in the ewelink app, but in alexa the video does not load it is black. Can someone help me?

Would you please send me a PM with your camera’s settings in the CameraGateway, let me check if there is something missing.

I think there maybe sth wrong with the RTSP url, Test & Validate Your RTSP url before setting it in CamSync is highly recommended, here is the guide below,

Software like VLC is needed

Using VLC, you can access your camera’s RTSP stream using the File > Open Network menu

Next, enter your RTSP URL in the “URL ” field and then click the OPEN button.

Once VLC has successfully connected to your camera stream, it will display the video stream in a new window.

That is means your RTSP url is correct and works, then fill it in CamSync with the same url and other settings may needed.


my settings. I can see the camera in VLC and the ewelink app, but not in alexa echo show 8.

the print screen is just above the PRINT hyperlink

Which one you have installed the Gateway in? Raspberry Pi or virtual machine run on ubuntu or other OS?
Please make sure the Gateway have the same IP section as the Camera.

raspberry pi 4. same network

in the ewelink APP the camera worked through the gateway

I would like to know if there is any restriction to work in Brazil. With this same configuration it worked once and then stopped

No Restrictions,
Works at beginning and then down? That’s wired, may I know your camera’s device ID? Will loop to our tech team for further check.

In app Alexa