Has anyone got the NFC function to work?

I am trying to activate a scene when I put my phone next to an NFC tag.

When I get to the part when ewelink says “Please hold your phone’s NFC area close to the tag” then the phone makes the NFC sound and a message “New tag collected” appears. The message looks like it is from the system or some other app, I mean it does not share the nice visual format of the ewelink app. And that is it, I cannot proceed.

How can I get rid of this?

(phone is Xiaomi Mi 9)


Maybe you should download an NFC tool first.
After you clear the Tag on the tool, you will be able to write it on the eWeLink App.
For more detailed steps and operation methods, you can click the link below to learn

1 Like

I have totally the same issue. All tags are new and cleared.

It just does not work does it. I have not resolved it since I posted in 2022.

I have tried two Xiaomi phones and a few tags but still no go.

I would like to signup to the ewelink pro, but if the free version does not work then it does not give confidence!

In my Samsung m52 phone, this functionality works without any problems.

I just tried to add an NFC tag again to see if anything had changed. I again followed the “Beginner’s Guide to NFC” procedure recommended by Natalia Long above.

I was incorrect that I still have the same problem which I reported at the start of this thread. I can now get past that - but I still fail to add the NFC tag to ewelink.

First I used NFC Tools Pro to add a text string “Fairy Lights” which is the name of one of my existing smart devices known to ewelink. That writes to the tag OK.


Then back to the tutorial…

See the “Written successfully” message which should appear at the final step - however I get “write failed.”

There is a “Retry” button but at this point it will no longer recognise the tag at all and times out with “no NFC tag detected.”

I really wish I could get NFC to work!

Writing to the Tag was unsuccessful several times.
erase with NFC tools - write failed - erase with NFC tools - write failed …
Written successfully !!!
I finished programming the scene, but scene the scene didn’t work.
Next day the scene worked, but not always.
The mobile always recognized the TAG, but the switch did not perform the operation.

Does your phone have always on NFC inward? Mine does not (iPhone X). It has always on out put and can read NFC but I need to be in an App that turns it on.
I thought the NFC idea was cool but then realised it’d never work with this phone. In just the next years phone I think it would.

I don’t even care about NFC. All I want is a very simple thing I can do to trigger a scene. Press a button. Not find my phone, start the app, click the correct icon…

NFC would be great, if it worked.