Google home does not activate the voice routine for closing the rolling shutters

Hello, I’m writing from Italy, these days I’m having problems with the routines of my dual R3 devices that manage the opening and closing of my shutters. I state that they have always worked correctly but from one day to the next when I ask google to activate the “GOODNIGHT” routine via voice command to close the shutters they do not close. if, on the other hand, I ask to close the single rolling shutter, the command is carried out correctly. The problem only occurs with the closure. the “GOOD MORNING” voice command routine I use for opening works fine. I have made several tests renaming the scenes for closing by connecting and disconnecting the Ewelink account and also contacting google support but I cannot solve this problem. Does anyone have any ideas on how to do this, or if they had a similar problem and managed to fix it? Thanks everyone for your support

Hi there, what did Google respond when you said “Good Night”?

hello, google home’s answer is: “Done” as if it had executed the command stop closing the shutters. To be more precise, the activity on weather information is also present within the “good night” routine. This is the only business that gets started

Could you send a screenshot to show me the routine you’ve created?

When you directly close or open the shutters via dual r3, does it work? I meant, just forget the Google routine and control the shutters directly.

It works perfectly. Both from google home by clicking on the icon of the shutter that I want to close and from Ewelink by always clicking on the icon of the shutter It works perfectly even if I ask to close the shutter with the voice command using only the name of the shutter that I want to close. The problem has only been present with the routine for a few days, it has always worked before. I haven’t done any recent firmware updates either.

It’s very likely that it’s a Google issue, so our suggestion is to contact Google for help. By the way, you can also change the voice command to something else, and ask Google with the new voice command.

I also think it’s a google problem. I already tried to contact their support but they were not able to solve the problem. Unfortunately, even setting up a new routine with a different voice command, the problem remains. Thanks anyway for trying to help me


I have exactly the same problem, I contacted google support but it says to contact Sonoff support… Difficult to understand where the problem comes from…