Google Assistant with eWeLink Switch Module

I have installed eWeLink 2 channel switch module onto an automatic fence. The app works perfectly with manual control, eWeLink app (both home devices or scene) after I changed the inching settings to 0.5second to do what they should do.

But when its linked and by voice command to Google Assistant, the fence opens up and closes right away.
It only shows the “on and off” switches instead on Google Home, I’m having trouble making Google Assistant to understand these channels need inching setting, it seems like Google Assistant over-writes eWeLink. Anybody know how to solve this problem?
It is convenient, but I wish it works perfectly with Google Assistant.
I also changed the names of the scene, but still no luck.

Isn’t there any inching setting in Automations (in Google Home)? You can start such an automation also on demand.

I haven’t seen any inching setting on Google Assistant

Maybe this will help? Create a routine, set delay.

Thanks! it worked, need to set the scene within Google Home’s automation.


We have two staff test this, and both work. Could you please tell us more about your setups? What eWeLink device are you using? Google Hub/Google Home version/account region?

Thx in advance.

Hi Ward,

Everything turned out fine as jam3 told me about the automations.
Basically I had to set the inching and scenes on eWeLink first and then Google Assistant needs automation for the task.

Another stupid question, is it possible to avoid “the fence on” when I tell Google “turn everything on”? As I had some other smart home devices, I do not want the Google to open the fence up (the fence opened at the same time, and closed right away as an error).

ps. I added “turn everything on” in automation on specific devices, and it solved the problem.

It is basically limited by Google itself, you can try to add a manual scene named turn everything on and see if it would work.

Some platforms would allow voice commands like turn everything on except XXX