GK-200MP2 unable to upgrade Firmware

I have bought two of these cameras. I battled to get the first one to upgrade its firmware, the second one fails every time - I tried dozens of times. Currently it runs 41220220712 as received from the factory. This version is not reading the 128GB SD Card. I have tried firmware updates on 2 different WiFi networks as well as LAN. My fortigate firewall forward traffic shows all traffic is allowed.

I tried updates with the SD card inserted and removed.
There does not seem to be a way to update this device. Please advise.

GK-200MP2B (fw name: GK-200MP2C) currently run version 41220220712 and show last version is 50420230103,but after you press to update the firmware, it just reboot and nothing changed.

While GK-200MP2-B(fw name: GK-200MP2D) & S-CAM upgraded firmware successfully to version 50520230320.

Hello guys, please kindly note that actually, the latest firmware for GK-200MP2C and GK-200MP2B is 41220220712. With that being said, you don’t need to update the firmware. You saw a new version notice as there is a mistake in deploying the firmware. 50520230320 is the new version for GK-200MP2-B and Cam Slim.

We apologize for the mistake. Please ignore it and don’t upgrade it if your camera model is GK-200MP2C or GK-200MP2B.

1 Like

I don’t agree with you.

I have a 200MP2B and 2C. The 2B has ver 5 firmware which it managed to download itself.

Ver 4 firmware does not support 127GB SD.

Ver 5 firmware does support it.

So until you fix your firmware downloading problem I am stuck unable to ship 2C cameras to customers.

Get BlueMail for Android

It probably doesn’t depend on the software, you need to format the SD in FAT32 (using standard OS means or some third-party program), because the camera does not recognize other formats

My camera is GK-200MP2-B and after the update I’m having trouble viewing the ewelink app and some other functions. I know the camera works, because the rtsp link is working on my NVR.

What stopped working:

  • image preview
  • camera movement (ptz)
  • rtsp configuration
  • image rotation
  • motion detection
  • microphone and speaker volume setting.

I already opened a support, but so far nothing…

Hi there, please reset the camera. It should work again after resetting.

1 Like

It worked. I was afraid of doing the reset and not being able to do the pairing. After the reset, I did the pairing, but it stuck again, I turned it off and it worked again.

thank you very much.

1 Like