Filebrowser add-on for iHost firmware 1.6.2 doesn't show folders

I just installed firmware 1.6.2 for the iHost and installed the recommend add-on filebrowser/filebrowser to browse the files on my SD card. Getting to run the add-on went with many bumps on the road and still doesn’t work like you would expect too.

First I discovered when you run the Docker container with the defaults in host mode the filebrowser won’t start as the logs indicate port 80 is already in use (for the main UI of the iHost ofcourse).
Then I started the Docker container in brodge mode and bridged host port 2000 to container host 80. After that I was able to open the filebrowser.

The next hurdle was the login credentials. I guessed it would be admin as username and admin as password. This was correct. After that I changed the password within the filebrowser settings.

After that I went to the filebrowser main content to view the content of the SD card and the view was completely empty. See the attached screenshot. I can;t find a setting how to set a default folder and which folder that should be. I also couldn’t find out which folder was being showed. The console didn’t allow any command to be executed.

I can’t find any instruction on how exactly the filebrowser should be configured. Can someone explain what the correct settings are?

Also I do miss a shortcut to the correct URL of the filebrowser. The Node-RED add-on has a handy arrow-icon at the UI of the iHost to open the correct URL.

1 Like

same problem, but some addon works like plex, iobrocker, openhab