Dual channel and Interlock mode


I have a problem with my dual channel device (model : psf-b04-gl) . It is well appaired. And I can toggle the two channel well too.

when the first channel is on if I toggle On the second channel, it turns off the first one and vis-versa.
So I look for the interlock mode wich is desactivated.

So how to toggle the both channel 1 and 2 ON together without unactivating the other one.
I tried to activate/deactivate the interlock mode in order to “reset” the mode.
But even after a rebooting and having performed an upgrade to the last firmware (3.7.3) . It doesn’t work.

I need some help before returning the product because it have no interest for me If I can not control the two channel independently.

Thanks for reading.

Hi there, it seems that you encountered a problem with the Dual-channel device’s disabling interlock mode can’t work. Have you tried to submit a support ticket through the eWeLink App? So that our support team can gather more detailed data to help locate the problem.


I just found my problem, There is an hardware switch I haven’t seen on doc. I only used the app switch wich doesn’t work when this button is not once pressed before.

problem resolved, thanks

but it could by better if the app can activate the mode directly, I though it could bypass the board switch.