Device triggers by itself

I have a Mini R2 that sometimes triggers itself without any action on the external switch or app.
Any ideas on how can this be solved?

Thanks

What do the device logs say is doing the switching?

Please find screenshot bellow and the action was at 4:34:43

No timers, inching or loops?

Nop. Nothing.

I have no MiniR2 but the miniR1 I have do not randomly turn on by themselves. Two of them are very noticeable. Is that just the latest firmware or did it happen in the last firmware too?

I just checked the logs of my 3rd mini1 in case it was secretly changing state but it does not. When an iHost scene changes turns it on or off it says my email did it, which confused me a while but the iHost scene obviously just uses my email because it is my account name for eWeLinkCube.

It happened again…
No one at home and device triggered itself.

What’s the default action when it turns on? Maybe it is a brief power cut triggering it.

It turns on a light.
I believe I will perform a reset and see if the issue still persists.

So if you cut the power to the house and then turn it back on it is set to turn on?

No, it’s set to off.

Sounds like a bug either locally or in the cloud. A couple of times I’ve had devices activate oddly and ended up resetting them. I think sometimes old scenes trigger them and you get “ghost” scenes even if you deleted the scene.

it happened to my switches. one time it just diconnect itself from wifi like the wifi connection been wipe off and i need to re pair the switches.

another time it just turn off by it self. without interaction from user.

i have since unpaired the affected switches and so far nothing weired happening. i believe it the cloud issues. nothing wrong with the switches.

I believe that I will reset the device and add it again.
Thanks for the support!

Had The same problem for sometime now. Devices triggered by themself and the log said that “triggered by a deleted user”. I tried reregistering of some of the devices but didn’t help. I have a to-link deco x20 4G lte router connected to the internet via landline. I also have a SIM card in it. If the primary connection does not function, the gsm takes over.
I suspected unstable landline connection and detached the deco x20 from the internet providers router forcing my deco router to connect via gsm). Problem solved.