CUBE Version 1.12.1 - any progress?

Version 1.12.1 did not result in improved functionality and did not fix the latest glitches. Tell us what you are doing about it and what progress is being made, please. Thanks.

Version 1.12.1 is pushed to some users to solve the matter pairing problem. may I know some details of the glitches you mentioned? did you submit a feedback with system logs?

Here you are:

Upgrading to 1.12.0 ruined Matter connection. All devices previously (with 1.11.x) added to Alexa became unresponsive although you could see that my iHost is paired. I decided to remove pairing and do it again. Unfortunately, it stops at the credentials generating stage. It then prompts you to check the post-processing instructions and/or displays a message about the need to connect to the network. I am unable to pair with both Amazon Alexa and Google Home.

There are problems with the eWeLink-Remote Control pilot feature. Occasionally devices added stop responding. You need to reboot to put things right. Also, the response time is longer than it used to be with 1.11.x.

Yes, I did. Please download it from here:!AnrXsF-IfTuXlMs2lfXYutBNwjo0UQ?e=HhecTb

V. 1.12.1 doesn’t bring any changes. It’s all the same with Matter pairing. Please see my previous posts.

Thank you and sorry for the trouble caused, we’ll look into your system logs and do some check.

You’re welcome. Mistakes and stumbles happen to us all, so there’s no need to be sorry.

Hi jam,
According to our dev team, the system log does not record the network configuration process. Have you confirmed that you were connected to the Internet at that time? You can try restarting iHost and try again, and can you please shoot a video? you can submit the logs and video by the feedback button again, and please let me know the ticket ID if you submit one.

Ticket ID: 197284

hi, better to remove your video anyone can see the matter code.


1 Like

This is for further investigation. Ticket ID 197325 is therefore linked to ticket ID 197284.

is it possible to get pushed to version 1.12.x for testing? i am having issues with all devices being removed and readded (without assigned named etc) everytime the ihost power cycles.
right now my ihost is next to useless to me

What are you talking about?! Why do you believe that problems with Matter protocol render your iHost useless? How often your iHost “power cycles”?
The iHost as Matter bridge is a new feature, still under development. It is for users who want to get a preview, try it out and shape it together with the developers before it is available in the final version. Something went wrong in version 1.12.x and the Cube guys are struggling to find a solution. This may be annoying for the user, but after all it doesn’t make iHost useless. Therefore, in my opinion you are strongly exaggerating and have a false opinion based on strange expectations.

For my needs and requirements loosing all device names and assignments in Google Home everytime the ihost power cycles renders it useless to me. That is a fact for me, it has nothing to do with your opinion.

When names and assignments are lost automations will fail and there is a lot of admin time when you have an large, and increasing, number of devices. I don’t have the time or inclination to re-configure my Google Home everytime my ihost power cycles.
You may and thats great for you but MY post was about MY requirements and not YOUR opinion.

I am not the only one with this issue and I have since spoke with a helpful forum user (not you obviously) who said this issue is actively been worked on.
I have full respect for the guys here and who are working on this, i simply stated my situation and it is not exaggerated. I am better off going back to using the ZB-Bridge Pro at the moment… rendering the ihost useless, as i stated.

Also with version 1.12.0 the matter bridge feature was not in pilot but in full release. It would be helpful to users if known or found issues were announced or documented somewhere but instead you have to search the forum and look for what other users have said and seek their assistance.

So there you go, i’ve explained it all to you. I could go into more detail regarding my exact setup and my lifestyle requirements on my setup and its functionality but that would make this post even longer and much like I could have explained much of this in my previous post, i was trying to keep it short.

Anyway, thank you for your opinion jam3 and seasons greetings!

With all due respect, you decided to buy iHost with the idea that it would be a Matter bridge? Matter support was added in version 1.11.x as a pilot in November and it worked. In version 1.12.0 they actually moved it out of the Pilot section and that’s when the problems started. This move was unfortunate and premature, as this is still in development: I understand your frustration. I, too, was disappointed that something that was already working well in early deployment was broken. However, I can’t say that iHost has become useless, because that’s not what it was created for and meant for. I wish you a bit of realism. And of course Happy Xmas. May peace be with you :sunglasses:

No i actually bought it some months ago under the impression it would integrate with Google Home as easily as eWelink and a ZB-Bridge Pro would but could replace them. This was based on the press and literature readily available at the time. The limitations of the local only operation and lack of native integration to other platforms was not realised by many, including myself.

I was ready to bin the ihost when matter become a main feature. At first i thought this sovled the issues i had with the unit, again i was disappointed, and again i wasnt the only one.

You keep making assumptions about why i bought or what my needs are but you are wrong each time.

I’ll let you have another go with your opinions and assumptions in the hope that you can win the internet for today and gain some validation.

Thank you very much for your attention and assumptions. You are more than absolutely right. Cheers.

1 Like

Hello, can you give me feedback on your system logs through the help center?