【Add-on Guide】 tts2cube-pico: Text to Speech add-on

Step 1
Navigate to the add-on (docker) menu,
Find the TTS2CUBE-Pico add-on on the page and install it
(in the CUBE v1.9.0 the add-on name is Pico Text-to-speech)

Or click Add add-on and search for tts2cube-pico to install it.
image

Step 2
Run the add-on

Step 3
Select the language and enter your text
Choose whether to save the audio
And choose where to play the audio, web browser or iHost speaker
Click the Convert and Play button to review

Click the File button upper right to manage the audio files:


Step 4
When creating a scene, you can select the audio as an action, when triggered, the audio will play on iHost.

I tried following the above steps. For me the add-on screen looks different (I specified port 8323:80), but I was able to get the add-on running:

The log looks fine, nothing strange:

And this looks normal as well:

But nothing loads on the admin site:

Do you have any ideas what the issue could be?

change the port, it should be xport:8323 in bridge mode and visit ip:xport
or simply use the host mode and visit ip:8323

I tried that as well, but the result is the same:

did you run the add-on in host mode?

Sorry my bad. Did not pay attention to the host mode. It is working now.

I am looking forward to additional functionality in this area, like adding my custom audio files and the actual text-to-speech examples.

the add-on has been updated, please check :grinning:

Hi @Teki
Thanks for the info. I updated the iHost to 1.9.1 and the TTS2CUBE-Pico was also installed. But when I go to the Web UI, I still only see the sample audio files, nothing else. This was already working for me, I don’t see any changes.
The scene setup is still like this, right?

did you uninstall the old one? please delete the old test one, the platform should be TTS2CUBE-pico
and you can create custom audios in the webUI of the add-on

is it also possible to add Dutch to the language? The English pronunciation is sometimes difficult to understand. Also sometimes the triggers from the ihost work slowly or sometimes not at all.

@Teki I deleted the add-on, and clicked on install again, but I get the same version back. Still the old version where there is no upload, just the default list. How can this be? I even did uninstall, iHost restart and install again. Still does not work.

How to play recorded sound ? I want to upload custom sound.

I have installed filebrowser addod , didnt find how to reach tts folder.

1 Like

this extension slowed down my device at first, and then strangely stopped working. I’m doubting it’s compatibility as I do use text to speech and voiceover APIs pretty often, not for this purpose but for large audio files renderings and yet this small code add-on had terribly lagged my devices for the time I had it on
they better undertake the bug fixing seriously

Hey Teki,
I have some questions.
How can AI text to speech functionality be further customized within the CUBE environment for more nuanced audio outcomes or integration with specific applications?