【Add-on Guide】TailScale - Remote access to iHost

TailScale allows you to visit your iHost remotely.

Note: Make sure you’ve updated your iHost (eWeLink CUBE) to version 1.8

Step 1

Register and login on TailScale https://login.tailscale.com/

Step 2

In iHost, go to Add-on menu (Docker) and install the tailscale/TailScale add-on

Step 3

Run the TailScale add-on

Step 4

Step 5

  • On the TailScale page,click the Download button upper right to install TailScale on your other device (PC/Smart phone), login with the same account and connect the device.
  • On the connected device (running TailScale), you can visit iHost remotely via the IP address displayed on the TailScale page.

Am I doing something wrong? I can’t get TailScale to use the volume I created.


Thank you for the feedback, we are aware of this problem and will fix it in the next version.

1 Like

Thanks for sharing. I managed to make it up and running with default setup. Quick question on Notification. Since this allow us to use browser at client (i.e., iOS) to access iHost.local/cast. How do we get notification work?.

The add-on didn’t work. In the ihost interface, when clicking the “Go to Tailscale” button, the address is opened. Then the following error message is displayed:
Failed to connect to local Tailscale daemon for /localapi/v0/status; not running? Error: dial unix /var/run/tailscale/tailscaled.sock: connect: no such file or directory.

In the Info tab of this add-on, the port information is empty.

Log page

2023-08-29T20:00:26.063757055Z boot: 2023/08/29 20:00:26 Starting tailscaled

2023-08-29T20:00:26.065369370Z boot: 2023/08/29 20:00:26 Waiting for tailscaled socket

2023-08-29T20:00:26.213423501Z 2023/08/29 20:00:26 logtail started

2023-08-29T20:00:26.213563791Z 2023/08/29 20:00:26 Program starting: v1.48.1-t0e9f04c83, Go 1.21.0: string{“tailscaled”, “–socket=/tmp/tailscaled.sock”, “–statedir=/data/tailscalState”, “–tun=userspace-networking”}

2023-08-29T20:00:26.213653332Z 2023/08/29 20:00:26 LogID: 723152c669382ffcbf0198d2015655c7531ab9403b98fa71cc42c1a2b7d168cb

2023-08-29T20:00:26.213715748Z 2023/08/29 20:00:26 logpolicy: using system state directory “/var/lib/tailscale”

2023-08-29T20:00:26.213775539Z logpolicy.ConfigFromFile /var/lib/tailscale/tailscaled.log.conf: open /var/lib/tailscale/tailscaled.log.conf: no such file or directory

2023-08-29T20:00:26.213868871Z logpolicy.Config.Validate for /var/lib/tailscale/tailscaled.log.conf: config is nil

2023-08-29T20:00:26.216949419Z 2023/08/29 20:00:26 wgengine.NewUserspaceEngine(tun “userspace-networking”) …

2023-08-29T20:00:26.219422432Z 2023/08/29 20:00:26 dns: using dns.noopManager

2023-08-29T20:00:26.220652668Z 2023/08/29 20:00:26 link state: interfaces.State{defaultRoute=eth0 ifs={docker0:[] eth0:[]} v4=true v6=false}

2023-08-29T20:00:26.226760390Z 2023/08/29 20:00:26 magicsock: [warning] failed to force-set UDP read buffer size to 7340032: operation not permitted; using kernel default values (impacts throughput only)

2023-08-29T20:00:26.226986720Z 2023/08/29 20:00:26 magicsock: [warning] failed to force-set UDP write buffer size to 7340032: operation not permitted; using kernel default values (impacts throughput only)

2023-08-29T20:00:26.227526589Z 2023/08/29 20:00:26 magicsock: [warning] failed to force-set UDP read buffer size to 7340032: operation not permitted; using kernel default values (impacts throughput only)

2023-08-29T20:00:26.227719379Z 2023/08/29 20:00:26 magicsock: [warning] failed to force-set UDP write buffer size to 7340032: operation not permitted; using kernel default values (impacts throughput only)

2023-08-29T20:00:26.229078821Z 2023/08/29 20:00:26 magicsock: disco key = d:f385380da73f7e7d

2023-08-29T20:00:26.229178862Z 2023/08/29 20:00:26 Creating WireGuard device…

2023-08-29T20:00:26.229895187Z 2023/08/29 20:00:26 Bringing WireGuard device up…

2023-08-29T20:00:26.230708344Z 2023/08/29 20:00:26 Bringing router up…

2023-08-29T20:00:26.231755124Z 2023/08/29 20:00:26 Clearing router settings…

2023-08-29T20:00:26.232817070Z 2023/08/29 20:00:26 Starting network monitor…

2023-08-29T20:00:26.234850547Z 2023/08/29 20:00:26 Engine created.

2023-08-29T20:00:26.257295205Z 2023/08/29 20:00:26 pm: migrating “_daemon” profile to new format

2023-08-29T20:00:26.265986189Z 2023/08/29 20:00:26 logpolicy: using system state directory “/var/lib/tailscale”

2023-08-29T20:00:26.267907667Z 2023/08/29 20:00:26 got LocalBackend in 51ms

2023-08-29T20:00:26.268490993Z 2023/08/29 20:00:26 Start

2023-08-29T20:00:26.274858879Z boot: 2023/08/29 20:00:26 Running ‘tailscale up’

2023-08-29T20:00:26.278290881Z 2023/08/29 20:00:26 Backend: logs: be:723152c669382ffcbf0198d2015655c7531ab9403b98fa71cc42c1a2b7d168cb fe:

2023-08-29T20:00:26.279274078Z 2023/08/29 20:00:26 Switching ipn state NoState → NeedsLogin (WantRunning=false, nm=false)

2023-08-29T20:00:26.279889779Z 2023/08/29 20:00:26 blockEngineUpdates(true)

2023-08-29T20:00:26.280006153Z 2023/08/29 20:00:26 health(“overall”): error: state=NeedsLogin, wantRunning=false

2023-08-29T20:00:26.281126140Z 2023/08/29 20:00:26 wgengine: Reconfig: configuring userspace WireGuard config (with 0/0 peers)

2023-08-29T20:00:26.281644134Z 2023/08/29 20:00:26 wgengine: Reconfig: configuring router

2023-08-29T20:00:26.281978963Z 2023/08/29 20:00:26 wgengine: Reconfig: configuring DNS

2023-08-29T20:00:26.282305918Z 2023/08/29 20:00:26 dns: Set: {DefaultResolvers: Routes:{} SearchDomains: Hosts:0}

2023-08-29T20:00:26.282396042Z 2023/08/29 20:00:26 dns: Resolvercfg: {Routes:{} Hosts:0 LocalDomains:}

2023-08-29T20:00:26.282543624Z 2023/08/29 20:00:26 dns: OScfg: {Nameservers: SearchDomains: MatchDomains: Hosts:}

2023-08-29T20:00:26.321290512Z 2023/08/29 20:00:26 Start

2023-08-29T20:00:26.326300704Z 2023/08/29 20:00:26 generating new machine key

2023-08-29T20:00:26.326506035Z 2023/08/29 20:00:26 control: client.Shutdown()

2023-08-29T20:00:26.326802948Z 2023/08/29 20:00:26 control: client.Shutdown: inSendStatus=0

2023-08-29T20:00:26.327440232Z 2023/08/29 20:00:26 control: updateRoutine: exiting

2023-08-29T20:00:26.328269723Z 2023/08/29 20:00:26 control: mapRoutine: quit

2023-08-29T20:00:26.328420513Z 2023/08/29 20:00:26 control: Client.Shutdown done.

2023-08-29T20:00:26.329037089Z 2023/08/29 20:00:26 machine key written to store

2023-08-29T20:00:26.330827319Z 2023/08/29 20:00:26 Backend: logs: be:723152c669382ffcbf0198d2015655c7531ab9403b98fa71cc42c1a2b7d168cb fe:

2023-08-29T20:00:26.331428728Z 2023/08/29 20:00:26 Switching ipn state NoState → NeedsLogin (WantRunning=true, nm=false)

2023-08-29T20:00:26.331723600Z 2023/08/29 20:00:26 blockEngineUpdates(true)

2023-08-29T20:00:26.341082784Z 2023/08/29 20:00:26 StartLoginInteractive: url=false

2023-08-29T20:00:26.341711610Z 2023/08/29 20:00:26 control: client.Login(false, 2)

2023-08-29T20:00:26.343325675Z 2023/08/29 20:00:26 control: LoginInteractive → regen=true

2023-08-29T20:00:26.343466840Z 2023/08/29 20:00:26 control: doLogin(regen=true, hasUrl=false)

2023-08-29T20:00:27.872839259Z 2023/08/29 20:00:27 control: control server key from https://controlplane.tailscale.com: ts2021=[fSeS+], legacy=[nlFWp]

2023-08-29T20:00:27.874114702Z 2023/08/29 20:00:27 control: Generating a new nodekey.

2023-08-29T20:00:27.979215327Z 2023/08/29 20:00:27 control: RegisterReq: onode= node=[v2Cd+] fup=false nks=false

2023-08-29T20:00:27.984041772Z 2023/08/29 20:00:27 control: creating new noise client

2023-08-29T20:00:29.105333794Z 2023/08/29 20:00:29 control: RegisterReq: got response; nodeKeyExpired=false, machineAuthorized=false; authURL=true

2023-08-29T20:00:29.106021244Z 2023/08/29 20:00:29 control: AuthURL is Tailscale

2023-08-29T20:00:29.106597279Z 2023/08/29 20:00:29 Received auth URL: https://login.tailsc

2023-08-29T20:00:29.106742527Z 2023/08/29 20:00:29 popBrowserAuthNow: url=true

2023-08-29T20:00:29.107739141Z 2023/08/29 20:00:29 blockEngineUpdates(true)

2023-08-29T20:00:29.107910056Z 2023/08/29 20:00:29 stopEngineAndWait…

2023-08-29T20:00:29.108952752Z 2023/08/29 20:00:29 requestEngineStatusAndWait

2023-08-29T20:00:29.109265707Z 2023/08/29 20:00:29 requestEngineStatusAndWait: waiting…

2023-08-29T20:00:29.110319195Z 2023/08/29 20:00:29 requestEngineStatusAndWait: got status update.

2023-08-29T20:00:29.110881230Z 2023/08/29 20:00:29 stopEngineAndWait: done.


2023-08-29T20:00:29.113139287Z To authenticate, visit:


2023-08-29T20:00:29.113344618Z Tailscale


2023-08-29T20:00:29.113524574Z 2023/08/29 20:00:29 control: doLogin(regen=false, hasUrl=true)

2023-08-29T20:00:29.118924137Z 2023/08/29 20:00:29 control: RegisterReq: onode= node=[v2Cd+] fup=true nks=false

im having trouble with tailscale. i have signed in with my google account and when i click Go to Tailscale, a new browser page opens and some script appears but if fails

. My iHost is having issues with tailscale. I have also copied the error into this reply.
I may have done something wrong. The two deices I tried with are running ok (a windows pc and an android tablet)

Failed to connect to local Tailscale daemon for /localapi/v0/status; not running? Error: dial unix /var/run/tailscale/tailscaled.sock: connect: no such file or directory.

Step 4 - is where I’m having trouble.

can I uninstall it and re-install it?

I have Tailscale working fine but is it possible to have a simplified interface for phones? I would guess most people who would want to interact with the iHost VPN Tailscale would do so on a mobile device and the iHost web page does not function well on my phone.

Also does the Tailscale VPN allow notifications somehow. For example, the burglar alarm is activated: is there a way to know if Tailscale VPN is there?

@edimarcr @coolawinebag
There is a problem with the web client module in the Tailscale v1.48.0 image package released by tailscale on August 16, 2023, which prevents the web ui page from opening properly.

We are waiting for tailscale to release a new version.

Hi Teki

Thanks for your response

I’m no technician. I would say my knowledge of trying to automate on my own, is less than Novice.

Perhaps ‘Dumbass’ would be more appropriate :blush:

Does this mean I cant access the iHost remotely? (this is the main reason why I bought this product)

So where to from here?

I question I asked in the forum – can I uninstall tailscale and then reinstall it?

Looking forward to some positive news.



Hi, I mean there was a bug in Tailscale, tailscale is a third-party service, they will fix the bug soon, once fixed, you may need to update the Tailscale add-on, and then it will work normally, you can access iHost remotely. Please go to the ‘info’ page to check if there’s an update.

Unfortunately i faced this issue as well :frowning:
Is it possibble to downgrade tailscale somehow until they fix the issue?
It worked stablr for me, until update…

1 Like

Good morning,
it’s possible add to the folder the files that need TailScale?

@coolawinebag @istvan
Hi, Tailscale will release the new update soon, before that, you can try the temporary method:
When you start the Tailscale add-on, go to its log page and find the authenticate link, visit the link to connect the tailscale service.

Thank you, i tried, but no success.
With above method iHost appeared again in the machines list at Tailscale console, but could not go online.
I hope next version comes soon and resolve it.

Thanks Teki,

Your solution really works. Ihost is now appearing in the Tailscale device list, but in my case I still have no remote access. When trying to open the Tailscale link, the error appears:

This site cannot be accessed. Unable to access http://100.125.x.x


A possible explanation for the error is a blockage in the router’s firewall.

I think the first and last configuration would be to release the listed UDP Ports (443 and 3478) for all IPs on the internal network. However, I couldn’t understand the second configuration.


:41641 to * : *


There were an update in Tailscale, but still no success.
Is there any other addon solution in order to reach iHost remotely via vpn?