Zigbee motion sensor and sonoff smart switch

Hello all,

I want to ask for help programming my ewelink application. My problem is the following.

I have smart switch in my kitchen, and I have zigbee bridge and snzb-03 motion sensor as well. I have 3 cats in my flat, and I don’t want them to switch my lamp with their moving. I create a scene only for switching off the kitchen lamp.
“If Smart Device Switch Kitchen on AND (all condition is met) Smart Device Motion Sensor Kitchen no motion detected (means nobody is in the kitchen but the light is on) Then Delay 1 min AND Smart Device Kitchen Switch OFF”

But what is happening in real:
If I switch on the light in the kitchen with the smart switch, it turns on what is good, but I leave the kitchen for e.g. 30 sec, then I go back again, so the motion sensor should recognize it, but unfortunetelly the lamp turns down after I while.
This is only when I leave the kitchen and go back again.
Can somebody help me how to modify the scene to avoid this behaviour?

When the Sonoff motion senser is triggered there is a delay of approximately 60 seconds before motion will trigger it again. Consequently, if you return in under 60 seconds the motion sensor will not trigger again. You could set an auto scene which turns the lights off when the motion sensor no longer detects movement and then add a short delay.


Thanks, for the answer, but the problem IS, that the lights goes off, although I am in the kitchen. I don’t want it.

Currently this is my kitchen scene

I am using the SNZB-03 motion sensor to check when someone enters a room. The only state I can check is either “motion detected” or “no motion detected”. You appear to be checking a status “clear” so I suspect you are using a different motion sensor. I also found that a motion sensor can sense “motion” when you move across the sensor, but it is not very good at sensing “presence”. i.e. when someone is present but not moving. The only solution I found to this was to use two sensors – one that detects motion when you enter a room (which turns lights on) and a second motion sensor which picks up the movement just outside a room on the way out and that sensor is used to trigger the lights off. It is also useful to use the real-time status screen on the ewelink app on your phone to monitor the status of the sensor whilst you are outside the room whilst someone else carries out the actions you are carrying out by going into the room, leaving and then entering the room again after 30 seconds. You can then see in more details what the sensor is “seeing”.


Sorry, on mobile app, the motion sensor states are motion detected, and no motion detected, as you said, but I copied my scene from eWeLink web, where the motion sensor states are motion and clear, but those are the same. Btw. I could solve the problem yesterday. The solution was, that I don’t have to put any delay in the scene, because there is an automatic timer in the motion sensor. So it behaves the following: If motion detected in the room, it’s timer starts for about 1:15 mins. If you stay in the room while the timer counts, the motion sensor will not change its motion detected state. But if you leave the room for more than 1:15 minutes, it change its state to no motion detected and you can use the scene to turn off the light. But if you go back to the room within 1:15, the motion sensor will not change its state, the light will keep its state. So you don’t have to take care about putting any delay to the scene. You only have to creat a simple one, what I sent in the attachment . And it works perfectly. It was a day of reverse engineering for me, to get to know this working

A(z) iOS Outlook appból küldve

I’m pleased you were ab le to get a solution that worked for you. I think the one important thing I found out when I started using the motion sensors is that there is this in-built delay in the sensor after the sensor detects motion. Excellent.

1 Like