The Micro SD Card is not inserted into the camera

Hi. I find that so weird because I also have 3 x GK-200MP2-B cameras and I am in South Africa and the latest update 50420230103 is definitely out and available. I have upgraded already.

1 Like

It’s true that 50420230103 is available to GK-200MP2-B, however, jeandrep’s camera model is actually GK-200MP2B. Two different models.

What is the latest version you have updated to?

Is it true that the following are entirely different models?

If so that is terrible naming by Sonoff.

Is it not more probable that Jeandrep just forgot the the last ‘-’ when typing it out?

When visiting:

I can only see GK-200MP2-B.

I have managed to upgrade to version 50420230103 which is the latest version as of this moment in time :slight_smile:

1 Like

For sure GK-200MP2-B and GK-200MP2B are different in that their chip capacitiy differs. GK-200MP2-B is a latest version while GK-200MP2B is an older model. That’s why on Sonoff store, we can only see GK-200MP2-B as the older model discontinued.

1 Like

Hi Peter, I have the same problem. I have tried card capacity 64G and 128G and the camera don’t see them. Both cards were tested on another device.
ID a63002095b
Firmware GK-200BF6D
Version 50520230320

Hi there, did the camera successfully recognize the SD card before? Like before you update the firmware, does it work well?

It’s a new camera. First time I inserted an SD card after a firmware update.

What’s the file system of your SD card? Is it FAT32?

I tested 2 SD cards.

  1. 64G - new SD card with no marking about file system.
  2. 128G - used SD card in another device. I don’t know file system.

The camera sees no one of them.

Hi there, in this case, we suggest you reach out to Sonoff. Please bring it to their attention. This is about the security camera’s recognition of SD cards and we here at eWeLink can do nothing to the hardware side.

Should I contact Sonoff in case of the camera on the picture?

Sorry for the mistake. I think you should contact the seller or manufacturer mumubiz in this case.

I was mistakenly thinking it’s a Sonoff camera, but actually, it’s branded mumubiz. So we suggest you contact mumubiz for help.

Same problem here. Model: GK-200MP2-B. I bought it new a month ago, SD-HC 32GB formatted inside, it started working properly but after a couple of days was not recognized anymore.
Formatted again into a PC, reinserted, just worked for another few minutes, then stopped again, the cam does not see it. The SD works into other devices. The FW is the latest available, currently 505202303…

When did the camera fail to recognize the SD card? Before the update to firmware or after?

It was already before the update, then I updated but didn’t solve.

Could you reset the camera and try again? If the issue persists, please feel free to submit a support ticket in eWeLink App.

Yes, I will give another try. Thanks

Hi all.
I have 2 GK-200MP2-B camera and I have inserted a 128 GB sd, card but is not working.
It say “Memory noy inserted”.
I have tray several times, but is not working.
Firmware version says is the last in the camera.
I thanks the help!