The "event-state" node loses the token if iHost is rebooted

An error occurs at the “event-state” node in Node Red (ewelink cube)

-I use the “control-device” and “event-state” nodes
-I get the token from iHost
-Everything works correctly (on/off with “control-device” and receiving data from iHost with “event-state”)

-If I stop/start iHost (reboot), the “event-state” node no longer works (I no longer receive data from iHost)
-The “control-device” node still works correctly.

I think that the “event-state” node loses the token if iHost is rebooted

the node keep the ip, when your ihost reboot, its IP may change, try to set static IP for your iHost

iHost has static ip

the “control-device” node works correctly with the same token

We’ll look into this issue

how do you put a static ip in ihost?
I can’t find this option

I assigned the ip address in the router using the mac address

Thank you. solved.

you need to do this on your router’s management page, try to google ‘your router model number + static ip’ for instruction.