Scenes does not enabled or disabled from a manual scene or from auto scene

Thanks. I’ll try this.

Hello
I am still somewhat confused about how to property set up my THR320D (also have TH16R2 trying to execute the same thing). Sometimes it simply does not activate.

Want I need is very simple. Unit is controller a hot water tank (cylinder) heater. If temp drops below 40c turn it on, once at 60c turn it off. 24 hours a day.

Do I need to turn off all Manual schedules? For example once a week I had it come on in the middle of the night for 3 hours as a safety heat up for legionella.

What do I need to enter to make this work as my current Auto schedule does not turn on sometimes and must have something to do with crossing the temp threshold and not triggering. Thanks

Hi All,

@songal - would you have any news on the instant stop via other scenes? When would it be released?

Thanks a lot!

Hi, the enable/disable logic for scenes is under development and is expected to be fixed in the March 2024 Android release.

@songal
I have figured out that an autoscene can not trigger another auto scene. this is very important in automation.

In my example, I use 2 sonoff devices to know when the inverter battery is LOW or HIGH using the No NC of the inverter. These sonoff devices are called BATTLO and BATTHI. At startup, they turn on for 1 minute then off to signal the status of the batteries. there is always one online and one offline because both can not be on at the same time. BATTLO is a trigger a scene called BYPASS and BATTHI will stop the BYPASS

There is an auto scene also when the GRID power is on. I want to know when the GRID is on if the battery is low or high. When GRID is on, autoscene triggers BATTLO and BATTHI at the same time. whichever is online will turn on for 1 minute then off.

But since turning on the BATTLO or BATTHI occured inside an autoscene, the BYPASS scene will neither trigger on or OFF".

Thus an autoscene can NOT trigger another autoscene at least currently.

That’s ture.

Dear Songal,

Thank you for your reply.

  1. What is the time span taken for a single order to be performed in seconds ( excluding delays ) ?

  2. and when do you think the “Scene triggering scene” will be allowed? ( because i did a work around that does not work 100% due to the second problem explained below ).

  3. There is another thing that is very annoying in ewelink.

When the device is in ON state and turns offline then online, there is no trigger at power up for the new ON state because sonoff considers the whole time the device was offline that it was ON so no change of state thus no trigger.

It will help to consider when the device is powered down and offline ( not offline due to wifi disconnection ) as OFF. thus when the power comes back on and the default state is ON, OFF to ON change will trigger a scene to start ( especially those related to power control ).

D- It will be very helpful is you can make a status online that can be checked is true or not ( especially in power control ). Suppose i want to check if the power is from source 1 or source 2 ( they are never on at the same time ). I can check is Sonoff 1 is online or sonoff 2 is online to perform a task. This shall not be so difficult to perform.

  1. this needs to take into account the load on the server and network latency, normally within a few seconds all the actions of a scene can be done ( excluding delays );
  2. this is currently not allowed under any circumstances;
  3. If you specifically use a switch to listen for when the power comes on during a power outage, perhaps consider setting the switch to ON of Power-on State and 15 seconds Auto-off of Inching Settings (generally speaking, 15 seconds after powering on is long enough for the device to connect to the network), and then set a scene which the “IF” is switch turn off, “THEN” to send a push. Then you will receive a message from your cell phone notification when the power is on.
    Of course, the suggestion in point 3 is just my personal inference, so if you are interested, you can try to see whether it works or not.

Hi All,

@songal - would you have any news on the instant stop via other scenes? Will it be released in March?

Thanks a lot!

The latest App v5.4 already supports that after disabling a target scence via other scence, the target scence instantly stops execution (if it is running)

No its NOT working…

See the next simple example.

When Window Sensor is Opened then Socket goes On
When Window Sensor is Closed then Socket goes Off after 10 seconds.

When Window Sensor is Closed and Opened within 10 seconds and stays Opened then the Socket goes Off.
Meaning that the Smart Scene “Light Off” did NOT Disabled.

(My App is v5.4)

In these two combined scenes, the light is finally on because the scene “Light Off” is re-enabled within 10s.

Strictly speaking, when a scene in progress is disabled, with its “IF” fails, the routine doesn’t disappear completely (listening to and killing the routine requires a huge resource cost for the server…), but continues to execute every “THEN” after the queue, and makes an additional decision on whether the “IF” is in effect or not when issuing the command, and decides whether or not to issue instructions based on the additional decision.

If you want to enable “Light Off” again inside the “THEN” of “Light On”, please add a delay equal to that of “Light Off” before “THEN”. for example:
IF
Door Sensor Opened;
THEN
“Light Off”Disable;
Socket On;
Delay 10s;
“Light Off”Enable
This will solve that you won’t have a problem with opening and closing the window cycle once in 10s, though the expected result is still hard to control with multiple iterations of opening and closing the window in 10s.

In your example the “Delay 10s” is problem.
If Window Sensor Closed within this 10 s, then the Socket will never go Off.
(the 10 s is for this example)

The bottom line is that the command “Disable” does not work when the command “Delay” is inside the Smart Scene. And this is bug.

If listening to and killing the routine requires a huge resource cost for the server, then don’t listen and don’t kill the routine.
Let the routine run, but prevent the result of that routine to come to me :slightly_smiling_face:.

The scenario that i want to run is simple:

If the front door open then the light goes on.
If the front door closed then the light go off after 2 min from the last time the door was closed.

If i open the front door for 30 s and closed again (forgot my car keys), i want the lights to turn off after 2 minutes from the last time the door was closed.

This simple and useful task its not possible to run, if i cant disable the routine without any delay.

The routine is “do not listening to and killing” as you said, it only prevents the execution when issuing instructions, but there is no notification indeed. For example: repeatedly opening and closing windows is like shooting bullets in sequence, after a period of time (delay), the bullets hit the target in sequence, but only when they hit the target will you know whether the target has a shield (disabled), it’s very difficult to make a bullet disappear in flight.