Put-device-state node is not listing devices

Other nodes like device-control work fine, but not put-device-state




All node-red-contrib-ewelink-cube nodes work fine except for put-device-state which does not list devices

try to edit the Server to update the token

@Teki, I tried to do that, got the new token, but it didn’t work. The other nodes work perfectly.

I uninstalled node-red, installed node-red-contrib-ewelink-cube again, but it didn’t solve it. The put-device-state node is still having problems. Frustrating

Please, any predictions for fixing this bug?

maybe this video can help identify the problem

Hi, sorry for the misleading, this node is for device that registered from Node-red to iHost (virtual device), for the virtual device, refer to this video: SONOFF iHost: Virtual Device Tutorial - YouTube

Hello @Teki,

I performed the test here, and the virtual device worked correctly with the ‘device’ option, displaying the component as expected. However, I need to set the percentage at runtime for a specific component whose category is ‘curtain’, in other words, for a Dual R3 device.

A more appropriate approach would be for the ‘control-device’ node to have an additional property called ‘state’, which would receive a JSON, similar to how it works with ‘put-device-state’. This way, it would be possible to provide the necessary information to dynamically control the percentage.

Do these considerations make sense to you? Otherwise, how would you suggest informing and setting the percentage control on the device at runtime?



Indeed, the issue goes beyond what was mentioned in the previous messages since there is no support for powering on, powering off, or stopping a curtain, in addition to receiving a payload.