PSA: eWeLink requires Android 8 up to work properly via the Internet

From now on, the ewelink app for Android requires version 8 and higher, according to @ward.
If you have a device with a version lower than 8, the functionality of the ewelink application for controlling Sonoff devices via the Internet no longer exists.

Ewelink requires Android 8 up to work properly via the Internet.

On a device with version lower than 8, you can still log in to your account. But you can’t change anything per device. The application becomes useless in terms of what it is intended for.

What if you have Android 5 - 7? For you, the ability to manage Sonoff devices via the Internet using the ewelink application is over!

  • You can buy ewelink web… And control it this way, although it does not solve the problem 100%.

  • You can buy a device with a newer version of Android… Maybe you don’t have the $$$.

  • You can control devices in LAN mode to a limited extent in the ewelink application… LAN does not provide 100% of the benefits of the cloud, not every device supports this mode. Some things can only be set via the Internet.

Absurd move by Sonoff/eWeLink…

Ewelink lost the ability to connect and control devices.

Full access on my side and no changes that would cause a problem… No communication is blocked on my side. The only option for device control at the moment is the web because the Android application is useless at the moment.

Verified versions 5.0, 5.3, 5.4 are the same everywhere

LAN control works, I can also log in to the account in the application, but it does not establish any connection and, as a result, there is no device control via the cloud.

@yitie What’s going on?

It must be some local problem. At my place, control via the cloud works normally. Well, today the lag is maybe a bit bigger.


We have updated the cert of the app, so you will need a phone with at least Android 8.

Sorr for the inconvenience.

1 Like

This must be a dark joke???

I have 7 and there is no option to upgrade to a newer one. This is an absurd move!
A lot of devices, phones/tablets, suddenly cannot support ewelink… This is just a joke on the users.

Where is the information in advance that such a big change is taking effect… you should send information by e-mail early enough, it’s sick.

Suddenly, ewelink becomes useless for many people… From now on, if someone does not have Android 8 +, ewelink/sonoff should be avoided!

What about people who don’t have the web version and need online management… ewelink/sonoff has become useless. Also change the requirements for the application so that only Android 8 up and not some 5…

To be honest, I expected a lot from your company, but I did not consider such a brazen move. It’s like getting shot in both knees… You don’t do that!

I’m really !@#$%^&()_+ you’ve ruined the entire sonoff device control model… I’m really pissed !@#$%^&()

This is not how you deal with clients, no matter how difficult the technical aspects are.

So what am I supposed to do now? Win the lottery and replace all my devices with new Android ones? Joke and disrespectful treatment of customers!!!

According to @ward, this is a matter on their side and from now on only Android 8 up…

Normally !@#$%^&* eh :(((((((

Sorry again for this situation. The move was made in compliance with relevant security requirements.

If you don’t feel comfortable upgrading the system, we can offer you Advanced Plan to manage devices from the web.

1 Like

Seems like a regular thing, more and more certificate authorities lifted the requirements for new SSL cert too. From the device side, iOS is even more aggressive, asking me to upgrade all my devices to the latest for some encryption features or I have to unbind that device from my account.

I fully understand the security aspects and I pay a lot of attention to it myself, but put yourself in my situation, you suddenly find out that all the devices you used for ewelink are suddenly no longer suitable… You can get angry, right. :slight_smile:

I have had the Advanced Plan for a few years, recently I even extended it again, but it is only a prosthesis which does not replace the application 100% imho. If you want/can, add another year for Advanced Plan for my account. I have no choice but to use the web version… and maybe one day I will be able to replace all the older Android devices that currently serve as cheap and simple Sonoff management terminals. It was cheaper than NSPanel, but it ended. :frowning:

There is no method for adding a certificate in versions below 8? Maybe some magic proxy or something… Because logging in to the account still works, but everything else is off.

If you have the option to update the OS, that’s one thing, but with Android there has always been and is a problem that few devices and their manufacturer supported the update option.

If you have a device with Android 7, you stay on this version until the end. Alternative OSes are not really an option because they simply cannot be installed on most devices.

Of course, old versions of Android are generally not safe and without patches are defective and outdated. But if the device is used in a limited and thoughtful way, the risk drops to almost 1%.

My older Android devices don’t use the internet as everyday devices. They work as a specialized solution only with ewelink, they have a local firewall per application, they are behind NAT/firewall and no traffic from the Internet reaches them, so even old versions do not pose a threat.

In addition, the way these changes are introduced without any information or announcement. Such decisions were not made in 5 minutes, so it probably could have been made more friendly.

The way the ewelink application works is also strange. Many other applications have not stopped working and still support older versions of Android and this does not affect their security.

The application should be built in such a way that it contains everything needed and the OS version should not matter. Currently, Android 5+ is considered the minimum standard for applications, sometimes only some people build applications with higher requirements.

I would like to read what the problem is with the certificate that occurs in 7 and lower, but not in 8 and higher…? 8 is also old and has not been supported for a long time, so what’s the point?


We need more technical information, what is the problem and why were such decisions made and why couldn’t it be done differently?

What part of the OS is the ewelink application based on that poses a threat? The construction of the application should be fully independent of the OS and its resources such as certificates.

Unfortunately, it looks a bit as if ewelink didn’t want to do the hard work and went for the simplest route…

The latest version of the application should be fully autonomous with cloud connectivity and secure data transmission. Something stinks here and I would like to find out the truth from a technical point of view, where this unsolvable problem lies… perhaps it could be bypassed and the necessary changes could be introduced in the newer version.

Much larger applications still work without any problems on 7 and lower… even Google.

If you run a website or other platforms, you may know that the SSL cert will expire and when you renew it, it will only give you a new one with new requirements, changes of cert provider would be painful.

I use an auto-renew script for my blog site and find it troublesome to change the provider

You didn’t mention earlier that your devices with the eWeLink app work with historical versions of Android.
No need to grumble. After all, no one should expect support to last indefinitely. This applies not only to the eWeLink app. You shouldn’t really complain about this move because it was to be expected.

I know how certificates work… the website hosting model doesn’t really have much to do with it.

An expired or compromised certificate is one issue, but it has nothing to do with ewelink and the requirement for 8+.

Android 8 does not have any newer files than Android 7. The ewelink application should know where to connect and what certificate to expect from the server… the version of the operating system has nothing to do with it.

The built ewelink application has all the necessary parameters and data to make a call to the server using the API. In this model, the certificate is located on the API side. And the application should see what certificate to expect. In this option, it is enough to change the certificate on the server side and optionally make changes to the application, depending on how it is built. I don’t see any dependence on OS here.

That’s why I wanted to find out officially, from a technical point of view, exactly what it is about, and not just a laconic certificate and security…

And as customers, we have the right to see what exactly is the reason for such a sudden abandonment of so many Android versions. The thesis about the old, outdated OS is also not explained, because 8 is also old and not as modern compared to 7. Why is 8 suddenly the minimum, why not 11 or higher?

There must be a clear reason for this, but I can’t see it yet…

No, my friend, I completely disagree with your point of view.

Termination of support for specific OS versions is one thing and another thing is the sudden loss of communication for a running application.

I have the impression that you don’t distinguish between these two things.

One is the minimum requirement for the operating system on which we can install and run the application. Currently, it is OFFICIALLY Android 5 and newer according to information from Google Play!
This means that the application should work in the same way and fully correctly on all versions from 5 upwards!

The situation that has occurred is not ewelink’s abandonment of support for older versions of Android, it is a sudden blocking of its application to servers if the OS is lower than 8.

Once again, the application officially supports 5+, you can easily download it and run it on Android 7, what’s more, you can log in to your account and you can also see the device status! however, you cannot manage them! This is not the end of support for old OS versions, as most application developers abandoned Android 4+.
There are developers who create applications with a minimum of 5+, but there are also those who require 6+ or even 9+, but at the moment this does not apply to ewelink.

You are confusing one with the other… If tomorrow ewelink does the same for other versions and says from now on the application only works correctly on Android 15 and everything older is thrown in the trash. I understand that you will immediately accept the state of affairs because…

If ewelink/sonoff want to end support and raise the minimum requirements for their application, there are established rules for this in the devs world.

Saying that the OS is terribly outdated and you can’t demand anything. Nonsense, of course, as a paying customer, I will demand that the actual state corresponds to the actual state.
And currently the official minimum requirements for OS are lying!!!
If an application is distributed as 5+ compatible, it must be so, regardless of whether someone likes it or not.
If they want to change the minimum requirements for the OS, let them do it officially and clearly, and not quietly, because maybe no one will complain.

eWelink 5.4.0 officially requires Android 5+ as a minimum and should meet such requirements. Or in a civilized way announce the abandonment and increase of the minimum requirement.

However, under the cover of darkness, they quietly blocked a certain range of communication for their own application, not the fact that the application cannot be run lower than 8+.

Tell me about the sudden threat to the mythical certificate… Which is supposed to be in OS 7- but it is no longer in 8+ magic and sorcery…

The matter is clearly introduced quietly and suddenly without any regard for how it will affect some customers… typical of Sonoff.

And the culprit of the situation is not the old OS but the company’s policy and decisions.

As far as this is concerned, you are absolutely right. There was probably, as usual, a lack of coordination among the eWeLink guys. They are quicker to do than to think :tipping_hand_man:

Of course, I understand your upset, but it was unwise to rely on outdated OS devices. It was known that Google would abandon old versions of Android at any time.

Unfortunately, life… Not everyone has a budget everywhere and sometimes we have to improvise.

It wasn’t a problem for a few years, hardware with Android 5-7 worked fine, and I’m talking about hardware with 512MB/1GB RAM and a slow CPU. The times when there was no NSPanel or cube and ewelink-web itself was a shadow of what it is today.

Using older Android 7 devices was both financially possible and technically feasible.

The problem is that no one announced anything and suddenly we wake up with our hands in the potty.
I was very angry and now I’m just starting to feel sad…

Google drops support for Android quite quickly and manufacturers sometimes drop it even faster. However, this does not make the device unusable. As a terminal, ewelink worked perfectly. The usage model did not pose a threat under the account of an unpatched OS.

Maybe I’m the only customer who used 7 since it doesn’t hurt anyone else. :slight_smile:

But this is not how it is done and some specific explanations are required from the company.

For example, I still use tablets with Android 4 for weather forecasting and they work great and safely and I don’t plan on replacing them too soon. :slight_smile:

Maybe you can use community-supported ROM like LineageOS? They are offering Android 14 for the first gen of Pixel even Nexus 6

As more cert authorities stop support for old Android/iOS devices, this might be a budget-friendly choice.


Does this situation have anything to do with Sisense?

Unfortunately, there is no alternative OS option for my devices. :frowning:

That’s why this whole situation made me so angry. Not even the fact of changes, but the way of introducing them.
At first I think it’s just a technical problem on my side. So I spent a few hours examining the network and then I thought that maybe there was actually a problem on ewelink’s side. But here I believed that this is only a temporary problem that will be solved and that’s why I wrote a post. And then suddenly I find out that this is a huge change and it will stay that way.
Which makes you feel like someone attacked you in the street and punched you in the face of surprise…

Imagine how you would feel if tomorrow you found out that the ewelink application will only work properly on iOS of the latest version and Android is completely abandoned… If you don’t have iOS, you are in a black hole.

Such changes should be announced early enough… And if the situation is urgent because it turned out that a security bug was discovered and the situation requires urgent action, people should be informed minutes/hours after the fact that such a situation occurred and such changes took place.