Notifications get spammy when sharing home / devices with other users

I have shared some devices to some friends, and shared home to some people to.

I can see no way to show these people how to leave their notifications coming through, whilst not getting notifications from the home or devices I have shared?

Can we please have a checkbox in the app settings somewhere, either per home shared with us / per device shared with us - to enable / disable notifications?

If I am testing new devices or scenes - I notify a lot - people I share with will very likely not be interested in that though.

Not sure if I understand it correctly. You want to receive notifications when the shared users control your devices like turning them on or off, however, when you control the devices, you don’t want them to receive these notifications, right?

Maybe we can consider to add some options from two ways. One is to allow the owner to set don’t push notifications of my shared home, or shared the devices to the shared ones, or do not receive notifications from the shared the ones.

the use case is - I have multiple devices… when I am testing devices or scenes and automations - I set up notifications, so I can see when things trigger…

now I share my home to a friend - so they can come feed my pets…

Now I get complaints from my friend - because they are getting all the notifications for my house - but they cannot go into the device or scene settings that I can see, to remove the notifications for them…

To me a best case option - would be a option where, if someone shares their device, or home with you - that you could choose if you want to see those notifications… or limit it to only notifications for devices you own… or no notifications at all