IP cameras (rtsp-iHost)

I don’t see the IP cameras (rtsp mode)

I was able to add ip cameras (rtsp) but I cannot view images from these cameras

With the same RTSP addresses, I can see images from IP cameras on NSPanel Pro and VNC media player

Same here.

In the Browser Developer Console i see the following Error Message:

Uncaught (in promise) DOMException: Failed to execute 'setLocalDescription' on 'RTCPeerConnection': Failed to set local offer sdp: The order of m-lines in subsequent offer doesn't match order from previous offer/answer.


res.error => 110011

1 Like

I was able to add 2 axis cameras to the ihost. I also see this in the ihost and can also get an image of it in the ihost environment. These are not yet visible in the app on the phone, just like zigbee devices connected to the ihost.

it is very good that you see the cameras added on iHost

as for ewelink…iHost does not and will not be related to ewelink (only update)…you will not be able to see either the cameras…or the zigbee devices on the ewelink application

iHost is a 100% local hub… you can go outside with Node red

Even with version 1.5.5 it is not possible to see the pictures of an attached camera. :sleepy:



Make sure it’s the right RTSP address and port, my camera works well and I even add an ESP32 eye to iHost without problems, some cameras may need the username and password to get streams from it.

All IP cameras worked on the previous version of iHost

have you tried to reboot the camera? and make sure the ip is correct

the cameras have static IPs
I can view cameras on rtsp protocol both on nvr and NS Panel pro

Maybe you have the wrong RTSP address, i have three cameras added, just make sure you have the right address and username and password.

all the cameras were added on iHost in the previous version and they worked

on the rtsp protocol and on the same settings, I see the cameras on nvr and NSPanel Pro

the problem was solved with the new version 1.6
but…only after deleting the ip cameras from iHost and redoing the settings


Im trying to add this camera to ihost via RTSP but it will not accept it,
I have added the camera to CMS software and it works, I have added it to icsee app on android and it works but neither of these require a RTSP address not will they show me a RTSP address.
I contacted BESDER and they said…
rtsp:// is the IP of the device you will access to
554 is the port of RTSP service, and it can be changed in the device/network
user=admin is the user of which you login the device
password= no password
channel=1 first channel
stream=0.sdp?main streaming

I tried this but still no response.

Anyone added one of these successfully?

Have you try it again with the new update?

In the meantime I have tried it with version 1.6.2. Unfortunately without success. I also deleted the camera entries as a test and set them up again.

Regarding the tips that I should check the IP addresses: You can’t set up a camera in the iHost anyway if the IP address is not correct.

My cameras are from eufy. Two outdoor cams (eufy security Solo OutdoorCam C22) and one indoor cam (eufy security Solo IndoorCam C24). All three cameras have a fixed IP address.

And as written: With VLC, the cameras can be connected without any problems.

I think you need a passwort,i can not remember corectly but i think there is some generic password that works like 12345 or something like that