Ihost and Iobroker

Iobroker works very well in Ihost (by docker as host). I integrated a lot of things. All things in the ewelink account, wireless and zigbee (in sonoff zigbee bridge pro). But now it is not possible the integration with the internal zigbee coordinator of ihost (and the other internal devices), Could you cooperate for an ihost adaptor: iHost (Sonoff/ewelink) · Issue #833 · ioBroker/AdapterRequests · GitHub ?
I am also traying to use the plugin for homebridge installed directly in iobroker but what about configuratione file ?
“description”: “Add configuration for your accessories or platforms according to the docs of the plugins.”,
“accessories”: ,
This is the plug in working log in iohost
ham.1 2023-06-11 16:34:40.789 info Adapter uses Wrapper mode

This configuration file doesn’t work. What are parameters for use ihost devices , zigbee, etc with plugin homebridge-plugin-ewelink-cube installed in iobroker ?
“description”: “Add configuration for your accessories or platforms according to the docs of the plugins.”,
“accessories”: [
“platforms”: [
“platform”: “Ihost”,
“name”: “Ihost”,
“countryCode”: “39”,
“username”: “ihost”,
“password”: “xxxxxxxxxxxxxxxx”

Forget HAM. Use the HomeKit Controller.

How ?

I don’t have an instance of iobroker installed at the moment, but from the top of my head: In iobroker install the adapter HomeKit-Controller. In Instances go into the setting and link it with the homebridge installation (iHost) shown. I’ve had the problem that there was no homebridge installation. In that case go to iHost, uninstall Homebridge and reinstall it. Then it should be visible in iobroker.

Thank you very much. It works !:
2023-06-12 17:37:37.721 info IP- xxxxxxx
Successfully paired to device:

1 Like

I read on the forum that you have some experience with Iobroker on iHost. As you know HA without add-ons is useless so I’ve decided to try Iobroker, but I’m not able to get in to Iobroker. Do you run it as a host or bridge? If I run it as a host I don’t see ports in the info tab. I tried everything what I’ve found on internet but Iobroker page doesn’t open. If I run it as a brige and set port 1881 fe. result is the same. Could you give me some advices how to run Iobroker on iHost because I don’t have any expirience with Iobroker.

Port is 8081: http://ihost.local:8081/#tab-info From outside with vpn use internal ip

Still nothing. I can’t connect to Iobroker page.

Maybe I’m using wrong add on?
Should I install any other add ons (except ewelink cube) to make it run?

I have buanet/iobroker. Now cancel also iobroker volume and reinstall

Yes, @siemassie is correct on this. To run iobroker, delete all previous volumes for a fresh start and install buanet/iobroker. You can install it in Host-mode. It will then be reachable (after a few minutes!) under [iHost-IP]:8081.
If you want/need access to files within the docker container, you can follow the instructions posted by @Teki

This involves creating all needed volumes first, then installing Filebrowser and then the containers with the applications. If you choose to do so, you can map /opt/iobroker to a certain volume. This will contain all config files.

But I’d like to get back to Home Assistant: I have HA running with editable configuration files and HACS installed. This works. So you can install ingerations via HACS. The only thing missing, is “add-ons”. But in HA they are a sort of separate container anyway, so you could install those add-ons in a different container, right? iobroker is great, but if you are used to Home Assistant, you might as well go for that.

Thanks guys.
The key was to wait a few minutes.