Home Assistant - How to Use it?

Hiya everyone. I have not yet dived into the world of home assistant but I am keen to start to get some additional control and introduce more manufacturers devices (Hikvision etc). Can I run HA on the iHost or do I need to run HA on a separate server (like Raspberry Pi) and then synch them?

A good video to do what you ask for :wink:

Hiya, thanks @parizolli. The video is great except the last item in HA to search for HACS to enable the Sonoff devices doesn’t seem to work? I search for HACS and its not on the list?

Screenshot 2023-08-31 at 12.54.06

I can see you have already installed the HACS package by pasting it manually (like in the video at 1:50 https://youtu.be/OhugPsohwjE?t=116). So you’re good with this step.
HACS is for “Home Assistant Community Store” : see HACS as a way to get unofficial integration for Home Assistant that are not officially developed by HA team. On your screenshot, you are in the official menu for adding things in HA.
Go in your left menu, you can see “HACS”. That’s where you will find the Sonoff integration by AlexxIT for example.
It’s a bit complicated at first, but you will get used to it :wink:

The first image was from the video, I cannot find HACS (in the video 2:49)

Oh ok, I thought it was your own picture.
Did you download and unzip the files from hacs github ?
And restarted the Home Assistant add-on on your iHost (this last step is not shown in the video, just written at 2:11 ?

Yes I followed the instruction and the files seem to be in place?

don’t know if it matters, try to rename the Custom_components to custom_components ,
and restart HA by the upper right button in iHost add-on page. You should be able to find the HACS

Hiya @Teki thank you for the suggestion. That did indeed work, I can now find the hacs in the list but I now get an error?
Screenshot 2023-09-01 at 07.19.56

I think it does, it is case sensitive.

@matthewnmoore : what step ?

Try to follow this thread : reboot everything; HA, iHost etc… : HACS installing problem via integration "error: Config flow could not be loaded" - #20 by lcnittl - Configuration - Home Assistant Community

Hi @parizolli @Teki Thanks for the tips. I tried shutting down HA then rebooting the iHost. I then restarted HA. I removed the google speech to text, restarted again but I still get the same error?

you have to download to this address and it will work https://github.com/hacs/integration/releases/latest/download/hacs.zip

Hi! Installed Home Assistant in accordance with this article. Everything worked out. Question: Is it possible to access the SONOFF Zigbee 3.0 USB Dongle Plus, added to the USB port on the host, from the Home Assistant installed on the IHost? I didn’t find an answer anywhere.

I am quite expecting to transfer from HA to iHost totally as long as it works better.

1 Like

I think HAOS that can be installed directly to ihost will be released soon - Tim L is already running HAOS on ihost and using the on-board zigbee module. But for more detailed tutorials you need to go to the HA community for help.

1 Like

Hello, I followed the video from parizollu to install HA w/ hacs and sonoff integration, and I’m looking how to add the ihost itself so I can play with it from HA. Sounds like only adding a ewelink account is possible, not local devices ?

When configuring Sonoff LAN, you can choose the local-only mode

1 Like

Thanks, but could you provide step-by-step instruction please ? I tried switching from auto to local, adding a “any” entry without password, I still can’t see the ihost and its subdevices.

You could check their readme or open an issue in that GitHub repository. And I don’t think that integration supports iHost, you can turn to Matter Bridge to pull its subdevices to HA, but that depends on which install method you use for HA.

It would be easier for HAOS.