Node-red-contrib-ewelink cannot login anymore 403

Hi All,

I used to login ewelink with my nodered ewelink device node credential. Dont know what happen, suddenly cant login and give error 403. Anyone could give me advice on how to resolve this issue. I am using node-red-contrib-ewelink. It works perfectly all this while and now it is not working anymore.

Oi colega, estou com o mesmo problema, estava funcionando a quase um ano. Ontem eu alterei a senha e parou de conectar, agora não funciona mais de forma alguma. Está apresentando o esmo erro que o seu, 403.

Hi, ich habe das gleiche Problem. Es lief über Jahre, jetzt leider nicht mehr. Gleicher Fehler. Wäre an einer Lösung sehr interessiert :face_with_peeking_eye:

Guten Abend, ich habe heute einige Tests durchgeführt, aber immer noch keine Lösung. Hat jemand versucht, die Dienste zu aktualisieren?

Hi, I have the exact same problem but cannot find a solution ??

I haven’t been able to solve it either.

Maybe the owner/developer of the ewelink node red nodes could offer some help ??

@Teki Would you please try to duplicate this issue and find out what happened?

Hi everyone, just tried with the iHost CUBE V1.10.0 version, node-red works well.
have you tried to update the node-red add-on?
iand you can try to uninstall the ewelink-cube nodes and re-install to see if it works.

1 Like

Today for the first time, I’m trying to use Node Red to control my Sonoff 4CH Pro R3 relay. I’m running into your 403 error also. I’m using the ‘node-red-contrib-ewelink’ node as documented in several sources.

Has anyone solved this problem yet?

can you please post a screenshot? in which step did you encounter the 403 error?

“I updated everything, NPM, NVM, Node-RED, and reinstalled node-red-contrib-ewelink, but it still has the same issue.”

Someone who has eWeLink working on Node-RED could check the versions of NPM, Node.js, and Node-RED?

I have always used the node-red-contrib-ewelink with the account information I use in the eWeLink app for my devices, and it has always worked. I didn’t even know about this node-red-contrib-ewelink-cube. Can it work on this cube without the Sonoff hub?

There is some miscommunication here. I think this has to purchase the iHost gateway. In order for node-red to communicate with iHost gateway, u have to install node-red-contrib-ewelink-cube.

In our case, we do not need to purchase the iHost but able to use nodered to communicate with our local ewelink devices by just installing node-red-contrib-ewelink. Unfortunately, recently it stops working, we do know what happen. Unless, node-red-contrib-ewelink developer able to help on this by maybe doing some upgrade version or maybe there is a way on function node correct command lines in order to authenticate and receiving data from ewelink cloud server.

1 Like

Yes I have the same error, and I don´t want to buy the iHost I only want that node red comunicate with my sonoffs like earlier. Please can anyone help?

I wish Ewelink subscription might have such api for nodered and I don’t mind subscribe every year in which I already renewed the 2nd year of subscription fees. I believe it will attract more people to subscribe and in which it is not so expensive and affordable and reasonable price. This will add more value to Ewelink web bcoz we might have some customization to trigger or work with something using Nodered. Maybe any Ewelink developer able to help…

I ended up buying iHost because I liked the product and its benefits. The open API for Node-RED is going to be a plus; however, I would like it to work with Node-RED again, as it’s much more convenient. I don’t have an eWeLink subscription; I find it too expensive for what it offers.

@soovui @guilherme_felipe @donrossie @widowsson @seraparamim @BeRa
Hi, the ‘node-red-contrib-ewelink’ node is developed by an individual developer, the used ewelink api is too old, which has recently been discontinued and is no longer maintained.
Developers need to update the api to V2, refer to this:
You can leave a message to the developer on github: GitHub - ottoszika/node-red-contrib-ewelink: NodeRED nodes for eWeLink smart devices

1 Like

Hi Teki, Thanks a lot for your respond. Is that possible to post us a simple nodered flows example for us to retrieve information base on the api V2? Very much appreciated your expertise.

1 Like