Node js api issue since Aug 10, 2023

Is it possible that a limit for the number of queries has been exceeded?
Is there a daily or other time period limit?

Is this forum monitored by Ewelink?

Hey guys, your feedback received, check in progress, get back to you if we found something.

Edit at UTC 6:25 am Monday,
We have tested that IFTTT works well in EU, US and AS region,
@paternoga would you please try again and let me know if the issue exists.
It happens due to network fluctuation.

@pazzagsia and other guys, please let me know your scrips here with the api you calling for, our dev team checked there haven’t any modify with OPEN APIs, so need specific info, thanks.

Hi Yitie,

Thanks for you help, but it seems the issue is this there. I have made no change to my node application(ewelink-api) and I get the error below. And my account was used on this page to authenticate and reply to this message, so account is not locked. Has anything changed on the API side? Rate limiting for example. Thanks in advance.

{“error”:406,“msg”:“Authentication failed”}

This one? Issues · skydiver/ewelink-api · GitHub
Are you Martin M.? or you just using his repository for your project?

Check this please Error 401: Wrong account or password -- again · Issue #220 · skydiver/ewelink-api · GitHub

Hi Yitie,

Yes, i’m only a user of the ewelink-api project. I managed to get the API to work by adding APP_ID and APP_SECRET to the connector.

I’m waiting for my dev account to be approved on ( to create my own ID and Secret.


Hi Lourik, I’ve been informed by the eWeLink technical team that they review applications at a specific time each day.
Furthermore, once your application is approved, you can refer to this document for configuration: GitHub - coolkit-carl/eWeLinkOAuthLoginDemo

Hi Yitie,

thanks for your response!

IFTTT is still not working, all 1 channel plugs and sockets are not found in my IFTTT applets (and I have a lot!) while my 4 channel plugs and RF bridges still work with IFTTT. Very strange! I tried everything since the first occurrence on August 10th, I even deleted my ewelink connection to IFTTT (loosing all my ewelink applets…) and then connected with IFTTT again. The problems maintain and I wonder, why only a few people seem to be affected. I would be so glad if IFTTT would work again!

Concerning the API login: I will send you my code in a separate mail tonight. Also this problem still exists. I hope you can help me. Something strange must have happened on August 10th at 10:03 am (local time in Germany).

Thank you very much,

Good morning
i tried again but nothing seems to change, when trying to login with the ewelink-api (eWeLink API | Getting Started) it denies access.
I tried both with an advance user and with a new user (to understand if something had happened to my old adavance user). Both users work fine with both the android app and the “” web interface but not the api. I also tried using a default base script but it always denies access.

I hadn’t encountered any problems with IFTTT, it has always worked correctly, the two things are not connected in my opinion.

I also tried to reinstall node js and the ewelink package in another pc and it doesn’t seem to install anymore with the following error

C:\Windows\system32>npm install ewelink-api
npm ERROR! code ENOENT
npm ERROR! syscall spawn git
npm ERROR! path git
npm ERROR! errno -4058
npm ERROR! enoent An unknown git error occurred
npm ERROR! enoent This is related to npm not being able to find a file.
npm ERROR! enoent

npm ERROR! A complete log of this run can be found in: C:\Users\xxxx\AppData\Local\npm-cache_logs\2023-08-14T10_45_42_813Z-debug-0.log
…file “2023-08-14T10_45_42_813Z-debug-0.log”…
410 timing idealTree:fixDepFlags Completed in 1ms
411 timings idealTree Completed in 795ms
412 timing command:install Completed in 808ms
413 Verbose Stack Error: An unknown git error occurred
413 verbose stack at makeError (C:\Users\xxxx\AppData\Roaming\npm\node_modules\npm\node_modules@npmcli\git\lib\make-error.js:28:13)
413 verbose stack at C:\Users\xxxx\AppData\Roaming\npm\node_modules\npm\node_modules@npmcli\git\lib\spawn.js:37:26
413 verbose stack at process.processTicksAndRejections (node:internal/process/task_queues:95:5)
414 verbose cwd C:\Windows\system32
415 verbose Windows_NT 10.0.19045
416 verbose node v18.17.1
417 verbose npm v9.8.1
418 error code ENOENT
419 error syscall spawn git
420 error path git
421 error errno -4058
422 error enoent An unknown git error occurred
423 error enoent This is related to npm not being able to find a file.
423 error noent
424 verbose exit -4058
425 npm timings Completed in 1442ms
426 verbose unfinished npm timer reify 1692009943444
427 verbose unfinished npm timer reify:loadTrees 1692009943450
428 verbose code -4058
429 error A complete log of this run can be found in: C:\Users\xxxx\AppData\Local\npm-cache_logs\2023-08-14T10_45_42_813Z-debug-0.log

there seems to be a problem with ewelink-api

Thank you

Regarding the API login, have you also utilized the “ewelink-api” project on Github? (GitHub - skydiver/ewelink-api: eWeLink API for JavaScript)

If so, the issues you encountered are due to eWeLink team disabling the “Personal APPID” of that Github project (only the APPID has been disabled, the eWeLink API interface remains functional). This is in line with what our colleague mentioned in the Github announcement: CoolkIt: Announcement regarding the expiration of the APPID referenced in this project and the cessation of maintenance of the v1 interface, suggesting migration · Issue #219 · skydiver/ewelink-api · GitHub

We ceased the use of “APPID” referenced in that project because the open-source project “skydiver/ewelink-api” on Github has not been actively maintained for the past three years. The “Personal APPID configuration parameter” referred to in the project was also prone to misuse. Over these three years, eWeLink OpenAPI has undergone several important updates. To prevent negative consequences for numerous developers, we made multiple attempts to communicate with the developer of the Github project, but unfortunately, we couldn’t establish contact. Eventually, we had to officially announce the discontinuation of the APPID for that project after three weeks of notice.

Project link: GitHub - skydiver/ewelink-api: eWeLink API for JavaScript

If you’ve been using the “Personal APPID” referenced in that project, this change may impact you. However, there are solutions available:

Since the eWeLink team has disabled the “Personal APPID” referenced in the Github project, you will need to apply for your own account on the eWeLink Developer Platform to migrate the project. The eWeLink technical team has provided an example of OAuth2.0 login for “individual developers” to refer to during migration. Specifically:

If you prefer to log in through a non-OAuth2.0 method, you need to send an email to to apply for an APPID. Please also specify your specific use case or requirements in the email for expedited review.

The eWeLink OpenAPI v1 interface has been discontinued, and it will gradually be completely deactivated (no longer usable) in the future. Developers are advised to migrate to the V2 interface as soon as possible. For detailed guidance, please refer to:

Hi Pazzagsia, please see the reply below

ok for now i requested developer user.

It was very convenient ewelink-api, so we each have to develop our own API, right?

Hey Robert, please send one of the device ID and let me check.

Hi Yitie,

thanks for your quick response. One device ID that cannot be found is ‘10005eecb6’. IFTTT tries to load my devices for 20 seconds, but nothing is found with the message, I should try it later again. But my network connections are okay, therefore the reason must be another.


Dear Dukkha,

Thank you very much for your detailed answer!

Yes, indeed I have used the APPID in the GitHub project you have mentioned. I will try to migrate my project to the API v2, thank you for the different references which should help me when doing this.

May I use this thread again if I have further questions?


Dear Robert,

Certainly, feel free to utilize this thread for any further inquiries. Wishing you success in your endeavors.

Best regards,

Regarding migration methods:

1、ewelink-api-next - npm encapsulates all open v2 interfaces, including LAN functionality. Please fill in the APPID you have applied for.

2、This is an example of eWeLink OAuth2.0 login:GitHub - coolkit-carl/eWeLinkOAuthLoginDemo

1 Like

Yes, you can refer to this reply

Hi all, our technical team has released an open-source project as an alternative to the eWeLink API. For more details, please refer to this link.

Hello, I have the same authentication problem.
I’m using the node-red contrib nodes, based on the standard ewelink API.

I have a lot of ewelink devices , they are working with Alexa, but my domotic system is based on node-red that is not working due to the authentication problem

Hi Alberto. Did you manage to solve it? How?