Ewelink-cube with NSPanel Pro

how to use node-red-contrib-ewelink-cube with NSPanel Pro?

I tried to access (api-server) the IP of NSPanel Pro but I get the message: “IP connection failed”

The documentation is missing the point that you need to reach the NSPanel Pro API on port 8081. Try that one.


Thank you!
But…how do I confirm the token?
Is it possible to access a web page for NSPanel Pro?

Look at the image below the description of getting the token. There you see you have to press the device name of the device at the Settings screen of the NSPanel Pro 7 times. Directly after that you request the token within Node-RED. Again IMHO this can be explained better at the beginning of the description of that process.


It worked! I confirmed the token…
But…I tried a “control-device” node
The “category” and “device” boxes sound empty… no data appears in these list boxes

Please check if there are zigbee devices of the corresponding type and model are connected to NSPanel Pro. The API only support control devices that are directly connect to NSPanel Pro locally.

I don’t have zigbee devices associated with NSPanel yet

I will pair some zigbee devices to NSPanel Pro and check

I added 2 zigbee motion sensors

I receive information on the “get-devices” node but no information on the “event-state” node

The event-state node with a zigbee magnetic contact worked for a few minutes.

now a server error appears and the get-device node is also blocked

How I can do that in node red?.. let me add here a screen shot

I´m a beginner on node red and not sure how to do it.

Thanks for your help