SONOFF iPlug S40TPB not appearing in IfTTT

Purchased SONOFF iPlug S40TPB off Amazon as it listed IfTTT support as a feature. I’ve upgraded eWeLink to enable IfTTT integration.

No eWeLink applets on IfTTT seems to support this plug. I’ve tried the following triggers…

  • 1-Channel Plug turned on or off
  • Voltage goes above or below
  • Electric Current goes above or below

…and the results I get are like the 1-Channel Plug leading me nowhere…

"This trigger fires when your eWeLink Support 1-Channel Plug is turned on or off.

eWeLink Smart Home Account: No Nickname. (No other choices shown… is this a problem?)

Which 1-Channel Plug? No options found.

Turned on or off? On.

…surely S40TPB should be appearing for “Which 1-Channel Plug?” chooser instead of "No options found."

I’ve tried dis-connecting and re-connecting eWeLink Smart Home to IfTTT app.

Is this device just not supported yet?

Checking by tech team, get back to you ASAP.

I’ve “reconnected” eWeLink to IfTTT and now my updated name for my eWeLink profile (“Gord”) is reflected in IfTTT (instead of older “No Nickname”) however under “Which 1-Channel Switch?” I still see “No options found”.

I’ve tried rebooting my iPhone also.

Should I be trying to attach photos? (If it is unclear what I’m trying to do here.)

Maybe someone else with a S40TPB could confirm the device can be used, and tell me which type of Trigger I should be choosing? I can’t imagine it being anything other than these 3… “1-Channel Plug turned on or off” / “Voltage goes above or below” / “Electric current goes above or below”.

Hi, there, sth tricky happened in the integration with IFTTT, need time to location the issue and fix it.

As for the nickname, it’s a new feature of IFTTT which is still in preview stages, and the power up or down triggers won’t be supported due to the chipset’s capabilities.

Thanks for keeping me posted.

Sure, thanks for understanding.