Ihost won't connect with ewelink account

Still not received your account login request.
We’re suspecting the internet connection of iHost.

Are you using the docker feature of iHost?
Can you download an add-on, see if the download success or not?

No, docker doesn’t work as well, I can’t download add-on. I Know that it’s sounds crazy, but ihost is connected at local network that work for all devices, I’ve already used the ip address of ihost in my computer and internet works correctly. I don’t have a firewall, just a router between my local network and internet. Some time I feel like the ihost doesn’t have a default gateway or dns configured, just a feeling.

Could I simulate in my computer the url that ihost should access when I try to link with ewelink? I could connect in my computer to see if my internet connection is ok to get there I could share with you my public ip to monitor if I can get there. What do you think about it?

just a thought… what is your ip address? public or private… Could a NAT (Network Address Translator) network be the source of the error? My full address starts with 100. ???

@marcelo2 This is the same problem I had when I bought mine. You have to look into your Firewall Rules. I use Unifi UDM that created a block rule for iHost IP in the end I had to allow then remove the rule. What ever ISP Router you have you must allow the iHost to get out without any blocks until you to update past your version. But once you update to later version then it seem more easier to connect and update. Mine was initially on 1.6.3 I believe that needed eWeLink and my docker didn’t work as well until I remove and put allow rule.

nothing is configured on the firewall, but if the ISP use NAT (Means an IP address is shared between several subscribers), then the user does not see the rules. e.g. dyndns doesn’t work either. In my opinion…

Hi

problem solved…don’t know why.

suddenly the update icon appears…

Many thanks…

Karoly

1 Like

Hi, marcelo.
Are you still can’t receive any update information?

Hello there, i have also iHost, but i can not link it with my cloud account, the link that supposed to apear, is not there, and i can not generate the QRcode to scan it from my phone…

Hi, what’s your firmware version? the account linking feature has been removed since V1.12, if your version is lower than V1.12, please let me know your eWeLink account and device ID.

Good Morning,

Account

beveratosj@gmail.com

Device Info

eWeLink CUBE Version

1.13.4

Device ID
1001ec503d

IP Address
192.168.254.75

MAC Address
d0:27:03:4f:60:4c

Manufacturer
SONOFF

But I can not link them together,

Hi, now users don’t need to link eWeLink account with iHost.
Previously the linking was for OTA service, now your iHost can get OTA without linking eWeLink account, the linking feature has been removed since V1.12

1 Like

Hello, after connecting my newly purchased Sonoff IHost device to the internet, I accessed it from the computer. However, when I tried to connect my own ewelink account, it gave an incorrect password or account warning. I opened a new ewelink account to try again, but it still gave the wrong password and account warning. I can’t update because there is no update button. ihost firmware Version:1.4.2 Device ID:1001ec37ce Ewelink account:engintrn@hotmail.com . We thank you.