[Alexa related issue]Sonoff devices are automatically and randomly turning off

Do you use Alexa, as we found yesterday, if the Alexa and SONOFF devices are on the same LAN, such an issue will happen no matter if you linking the Alexa and eWeLink accounts or not. Why does this happen? We did not find out the root cause, but the key factor is Alexa. We are working together with some users to find out the root cause.

So if you used Alexa, please try to power off the Alexa and see whether this issue still going on, or you can remove the Alexa from the network and observe the behavior of SONOFF products.

Hope this helps.

Hy Daniel, don’t you have a solution yet? I have used Sonoffs for several years, and extremely satisfied.
So I started building houses now and decided to automate my houses with sonoff mini r2. But then I realized that they do not work very well, I have about 40 devices and almost all of them turn off automatically.
Please include my devices in the fw update lista as well.
I have tried everything you suggested, actually all my iot devices has fixed IP reserved in DHCP table, my 2.4ghz ssid is different from 5ghz, yes I have Alexa in this Smart Home, But 8 amazon echos and some of them embedded on the ceiling, so there is no way to turning off them.
Sonoff claims to be Alexa-ready but it seems not.
Actually I am having some equipments damaged since sonoffs sometimes reboot every minute.
I have all my pool pumps controlled by Sonoffs as well, but now it is being hard to keep the pool clean, since sonoff device powering is not reliable and I need pumps to be turned on for 6 hours daily.
I run Netgear R6400 routers with a managed Cisco Switch in this house, and I already bought a new Asus Rt-AX88u router to give my last try with Sonoffs.
I only didn’t switched to other brand yet because it is a lot of devices so I will loose a lot of money. But I am very disappointed.
This house is being used since December and Sonoffs blinks since the begining. In December was OK, it looked like Xmas decoration, all house blinking. But Xmas has already finished.
Please check waiting for a solution and prompt to help providing tests.

1 Like

Hi, i have tried all possible fixes and nothing seems to be working. I have tried the following

I first thought that my devices had gone bad so changed a few devices. But that did not work.

I then thought that there was a leakage of neutral, but my RCCBs were not going off. A quick check my the electrician proved that was not the case.

I was concerned that may be voltage is irratic and my grid has gone bonkers so i added a UPS on the line to check if that would do the trick but that did not help either.

  1. My device is on software version 3.7.3. i also manually added back a few devices to check if that helps.
  2. I have ensured that the DHCP range is between 151-255.
  3. I moved all Alexa devices to 5Gz network
  4. Then i moved Alexa devices to a separate router
  5. Then i disconnected the ewelink skill on Alexa
  6. I then tried switching off ip6 on my network. That did not do much so reverted back to having IP 6 in addition to IP 4.
  7. Currently, I have all my Alexa devices disconnected. Powered off. This included Fire sticks as well. All Except alexa on my phone.

After each of these steps that i have taken over the course of last two weeks, i have restarted the router. I cant allocate fixed ips to all my devices. That was the only advice that i haven’t been able to follow on this forum. At this stage, i can confirm Alexa should not be a reason. These devices are all switched off. Please help

1 Like

The last time the device above tripped was at 3:03 PM IST

I have 135 devices in use, mainly wall switches and mini, no Zigbee. Firmware which is currently up to date, depending on the device from 1.4.1 to 3.7.3. I use Alexa and Google Home, IP range for Sonoff from to 200, all fixed. DHCP from 230 to 240. AVM Fritzbox as a router, plus various repeaters, all from AVM, all in the mesh. As far as I know, the problem described here has never occurred to me. Various other concerns, yes. But not this one. Am I just lucky or what’s the difference? I would like to understand that.

To whom are willing to help address the issue together, please submit related information to speed up the issue fixed, thanks very much.


1 Like

Further update, a few hours after plugging out Alexa devices, i haven’t noticed the devices powering off randomly. It’s been over 36 hours now. So please ignore my comment around unplugging Alexa does not help. Unplugging Alexa devices is making a difference. It has been the longest period of time since my devices have not acted randomly in two months.

1 Like


We are working with the Alexa team to trace this device random OFF issue, and trying to isolate possible factors one by one, will discuss with the Alexa team to sort out a checklist or guideline to speed up the process, if you still have this issue exists and are willing to help us, please fill out the survey HERE in Daniel’s post, and will evaluate with Alexa team and get back to you ASAP and loop you with us and Alexa team members separately to further troubleshooting.

BTW, logs from echo devices are critical to locate this issue, and it’s time-sensitive which means the logs may be erased or recovered after the random OFF happens, it’s better that the issue still exists recently or if you can reproduce the issue is the best.

Thank you in advance.

I too had been experiencing this random off issue for the last months but it seems to have stopped after I migrated my Alexa’s echo dot’s (the only Alexa devices I have) to an independent guest wifi.

I left my 10+ sonoff mini devices and a couple of other sonoff devices (dw2 door sensor, and basic sonoff switches) connected to the 2.4 wifi (as they had always been).

I configured my router to broadcast a guest 2.4 wifi network and configured the Alexa dot devices to connect to the guest network.

I then had to block the access of the alexa dot’s to my “standard” wifi (in the MAC address options of the router) because they insisted on reconnecting to this wifi.

It’s been more than 4 days now and I have had ZERO issues!! Happy.

Hey, friend, happy that isolate the echo works.
Just like my post upper, we are working with the Alexa team to locate the possible reason of this issue, would you please help us with the issue locate progress? Some info and test to-do needed, let me know if it’s OK to you.

Thank you in advance.

Hey, friend, happy that cut the power of the echo works.

Just like my post below, we are working with the Alexa team to locate the possible reason of this issue, would you please help us with the issue locate progress? Some info and test to-do needed, let me know if it’s OK to you.

Thank you in advance.

Hi, I am happy to help. Let me know what you need.
Best regards

1 Like

I have mikrotik and never get the errors … I have only 20 devices

Dear Daniel,
Echo dot Alexa version 1 only allows working in 2.4Gz. I have like 5 sonoff 3.5.0. I can’t change the firmware.

Thank you, will get back to you if we and Alexa need more details.

Yo he tenido en mismo problema, lo que hago es que cada vez que uno falla, configuro el router para que le asigne una dirección arriba de los .200 con esto dejan de dar el problema.

So after 2-3 weeks of no issues, things are rebooting again, the catalyst was having to restart my router this evening, immediately after it rebooting I can see the NSpanel randomly restarting and I’m waiting to see which other lights in the house are now effected.
Are you any further forward in resolving this significant bug in your product?

We have clues to find out the root cause, please be patient and I believe that the issue will be fixed soon!

I have a total of 15 Sonoff Mini, I updated them to 3.7.0 firmware except for one which is still 3.6.0, and guess what the 3.6.0 is working without any issue while the 3.7.0 randomly turns off. So it’s clear the latest firmware 3.7.0 had some bugs which are causing this issue.
So why don’t you (developers at sonoff) just check the changelog of 3.7.0 with 3.6.0 and find out what set of code changes caused this issue rather than rolling out new updates suspecting issues with Alexa and network, etc, and in meantime roll back the firmware to 3.6.0 if that is possible.


It started to happen yesterday to me too. Randomly disconnecting.